Corruption in scene file with XRefs (can no longer reload/replace)?


Hey gang. Ive run into the problem a few times and it is haunting me again.

Im working with a product rendering scene that has the products themselves linked as Xrefs. The scene only contains a rendering environment, lighting and camera. The issue that I’m having is that with this particular scene i can no longer update my Xrefs. Selecting the XRef object in the object manager has the exchange, reload, open for edit and options buttons greyed out. When I open the Xref manager and select the XRef file and try to update/exchange it. nothing happens (for example if i try to exchange ti, the file dialog does not come up.)

Has anyone experienced this behavior? If so, is there a reliable fix/workaround?

Ive had this happen a few times in the past and my solution was to create a new scene. Trying to avoid that this time.

Currently using R19.053 but have had this same thing happen with previous versions.



since i started changing the standard setting of the file path for xrefs from relative to absolute it never happened to me again. i don’t know of any working fix for files where it already happened though except for making the xref editable. of course that totally defeats the purpose. if you had autosave turned on maybe just go back to the last version of your file where it wasn’t greyed out yet and set the file path in there to absolute. saved my ass in the past a couple of times.


also have you tried putting the xref file directly into the folder where your scene file is? maybe that could work since it seems to be a simple file path issue. just guessing.


Thanks Sebastian! I’ll try using absolute paths from now on.

I was able to “repair” the file by re-importing new xrefs and then finally being able to delete the old ones. Fortunately i did not have any animation applied to them in this particular scene. Just some xpresso connections and setups.


Just a little more followup in case anyone else runs into this.

The “corruption” manifests as an extra …/ in the relative path of the link. i.e. the correct relative path would be “…/some_folder/filename.c4d”. when it gets goofed up the relative link shows as "…/…/some_folder/filename.c4d". once this happens it is uncorrectable. Unchecking “relative to project” in the file options for the xref works around the problem. Unfortunately once the problem occurs, you can’t access the options, so you need to do this right away when you import the Xref.


makes me wonder why this has not been fixed yet, been around since r17 i think… seems like a rather easy thing to do. happy to hear you weren’t doing any animation with the xrefs, this issue was driving me crazy in the past until someone here told me about the file path thing.


Agreed. Ive also experienced it in older versions. Definitely a bug.

At least its good to know there is a way to avoid it, as long as you remember to do it on each import! Fortunately, in my case I mainly use XRefs for product models. (That way if there is a tweak in a texture or part of the model from the client, I only have to update in one master file.) I can’t imagine how much of a nightmare this would be if it happened with an xref’d character rig animated in a scene file!!!


Hi its 2021 on R23. I still have exactly the problem described. unfortunately with a animated character :frowning:


Could you please report the bug to Maxon?
I’m sitting on a bunch of complicated scenes using xref and stories like these are slightly unnerving :slight_smile:

everfresh thankfully gave me the tip for absolute file paths before diving into xrefs, and so far I didn’t have a single problem (even though I restructured my project/filepaths several times :D)