Contacting Maxon for Reinstalling Cinema 4D r19/r20


#1

I made a giant big “oopsie” yesterday which resulted in Cinema 4D r19 and r20 to not being able to launch anymore. Don’t ask me what, I have no idea. :slight_smile:

I still have the installers but the serials aren’t here. Maxon has discontinued the ePortfolio. Trying to contact them (create a ticket) results in a “email address is either reserved or not registered” error.

Reading the “What does it mean by my email address is reserved or not registered?” knowledge base article with all kinds of stuff that doesn’t help me at all, there is at the bottom this line: “If that fails to work, contact support.” Which… tada! trows me back to the beginning part with my email not being registered.

So I try to sign up for a new account, I already know whats going to happen but I’m optimistic, maybe it will work. Naah, nope! “UNEXPECTED ERROR
Oops!..Something went wrong. Please try again later or contact us if the problem persists.

So anyone any idea how I can contact Maxon and request them politely if they are maybe willing to send an old fan of Cinema 4D his serials for r19 and 20?


#2

I’d be interested too.
I had a HD fail a couple years back and lost everything (r20).
Fortunately I still had backups on an old external HD with 12 and 16.

Good luck


#3

I have a feeling you’re going to be out of luck because the ePortfoilio has gone. They gave us good notice and even though I’ll probably never use C4D again I wrote down all my serials and downloaded the installers. They were clear once it’s gone it’s gone…

I have everything backed up twice, I had to do it because of the amount of money I’d spent over the years.

I hope I’m wrong and you get your serials.


#4

I’m sure I wrote it down too. I just can’t find it anymore. Logical place to store it would be next to the installers but there is nothing.

I refuse to believe that when you have ordered for thousands of euro’s in the past, a company is unwilling (haha fat luck!), to help you with something like this.


#5

It’s even worse. I can’t even reinstall C4D, after selecting a language the installer quietly closes down on me.

I’m seriously forked. Only thing I did was when cleaning up my HD’s I found an old Blizzard Starcraft II game. Interested to see if that still worked I fired it up and a Blizzard installer started updating the files where it several times needed my admin credentials, to which I said ok.

I started up from another disk (same ancient MacOS X12), tried to launch C4D or the installer and both are still a no go.

Fork!


#6

Rikof

WTF! I wonder if the installer is looking online for an authentication server which is no longer there?

Can you think what you did that caused this problem to begin with? Have you changed security or network settings recently?

I’m running out of ideas fast here, sorry.

Hopefully someone else can think of something?


#7

From Maxon:

Cinema 4D R19 or R20 won’t start on newer Windows 10 Builds
Cinema 4D Support - jg
Cinema 4D Support - jg
Updated 8 days ago
Unfortunately, we discovered an issue with Cinema 4D R19/R20 on the latest Windows 10 Builds (20H2 and onwards).

After installation of Cinema 4D it won’t start or disappear immediately.

If you discover this issue, you should create a new rule in the Windows Firewall (or other firewall used), that blocks outgoing connections for Cinema 4D R19/R20.

This should solve the issue and Cinema 4D will start correctly.

The disadvantage is, that the online updater can no longer be used for automatic updates.

You can find a tutorial on how to create rules for the Windows 10 Firewall here:


#8

I think Rikof is on MacOS.

IIRC there’s a program called Little Snitch on the Mac which can block app communications if this is the root cause.


#9

Delete this folder and it will stop doing the thing where it opens and immediately shuts down.
C:\Program Files\Maxon\resource\libs\win64 in your R18, R19 or R20 folder.

I had a desperate need to return to R19, to bake down the results of a now obsolete plugin.
This tip from youtube worked for me.


#10

Thank you all for your tips and input!

Finally was able to fix it yesterday evening. My bootable 2nd HD was also having issues and with that I couldn’t start up any of the build-in emergency programs that come with a -Apple Mac-. :slight_smile:
But once that was fixed I could get to an backup from 2 month’s ago and set everything back.

With the Mac so old as this one (12 years) I no longer store most of my files on the drive with the ancient, cannot-be-updated-anymore, OS so I barely lost anything.

Still leaves the Maxon contact problem. The moment I use my email address Maxon’s server trows up. Like I’m on some sort of blacklist. :confused:


#11

That might be because they’re checking against an email database that your email address is not in i.e. only people who’ve purchased from R21 onwards with the new Maxon App licensing are in the database.

R20 and older customers no longer exist as far as being current customers and details are probably not kept. That’s my guess as to why your email is not being recognised, you don’t exist in the new system.

Do you have a local Maxon rep? Do local offices even exist anymore?


#12

My iMac is late 2009 too.
But, it’s still very operable.
Glad you got most of your problem solved.


#13

Everything works.
I turn my computer off, I sometimes do that, go to bed, wake up turn computer on and I’m back in the rabbit hole.
C4d won’t start, can’t access the backup system with control-r, it’s maddening.

Hows this possible when I put my computer 2 months back before this happened, virus got me?

@Infograph Ok but shouldn’t I be able to sign up for a new account? How the fork! do you contact these people if they blacklist your email?


#14

Sorry, I didn’t realise the system was preventing you setting up a new account. I’d be surprised if you were ‘blacklisted’ as such, why would Maxon do that?

Like most modern companies Maxon appears to be providing the minimum possible support even to new customers, legacy customers are really out of luck and have nothing more than the ‘Knowledge Base’ for help. Do Maxon have a discord server, they don’t have a forum for C4D only Redshift and Forger.

I’ve no idea what’s up with you Mac, it’s very odd behaviour. Have you tried resetting file permissions with disk utility? This has fixed problems for me in the past. It could be that when you shut down and files are written to the disk they can’t be updated due to a permissions mismatch and when you turn on again you’re back to square one.

When you do get your system up and running, even if it’s temporary, export your important assets as the Universe might be trying to tell you it’s time to use open source software. With R19/20 not booting on PC without blocking the firewall I think the writing is on the wall that pre-R21 C4D is at death’s door and it would be wise to make alternative arrangements.


#15

Hi guys, I have a similar problem.
I am still running Mac OS 10.11.6 and have Cinema 4D R18 and R19 installed.
Both have worked well (not together of course) for years… until a few days ago when neither of them would start.

The only thing I recently installed was an (Apple Store) update for “mobile devices", so I removed that from the system, restarted and tried again, but it still doesn’ t work.
Then I deleted anything Maxon related and tried to install R18 aigain. The installer asked for the language, I clicked English, … and the installer simply quit.

Anyone out there knows the answer?
Of course, I can do a clean install of the system, but I hate to reinstall all the stuff I use…

Peter


#16

@Peter-L

Hopefully by tagging @Rikof he’ll see a notification next time he visits and he can talk you through what to do if he got his issue sorted.

It looks like an old server that was contacted during the installation process is no longer available but I could be completely wrong on that.


#17

@Peter-L

You may have run into a long-standing, unresolved issue where one of the files updated through iTunes in OS X somehow prevents Cinema 4D from launching. You can check the following thread on Creative Cow for more details: https://creativecow.net/forums/thread/cinema-4d-r19-wont-launch-on-my-mac/

In summary, there’s a file at /System/Library/PrivateFrameworks/MobileDevice.framework that those older versions of C4D don’t like. Ideally, if you have a Time Machine backup of before you ran the mobile device update, you can pull that framework file from the backup and replace the new version that breaks your C4D. If you don’t have that, however, you may be able to download an older version of iTunes—12.8.2 for example—and install that with the hopes that it contains a version of the framework file that doesn’t break your C4D.

To note, keep track of the version number of the MobileDevice.framework file which can be found in the Get Info panel through the Finder. This will be helpful in keeping track of which version(s) of the framework to stay away from and which one works for you, should this be the solution to your issue.

Lastly, you most likely will have to temporarily disable System Integrity Protection (SIP) to replace the framework file manually. You can find details online on how to do that, or recommendations to replace the framework file in the Creative Cow thread. Obviously, when modifying any system files, do so at your own risk.

Hope this helps.


#18

R18, R19 both open on my old Macbook Pro running MacOS Mojave with iTunes 12.9.5.5 installed. I forgot these were installed but they did launch without problems to my surprise. I did have issues getting them to quit which I’ve never experienced before. There’s definitely odd behaviour creeping in to these old versions of C4D, so it’s probably a good idea to prepare for the worst before it happens.


#19

Just chiming in, after putting a 2 month old backup back, things seemed to work. Until I close C4D where it then locks up again. So I’m in a cycle of putting a now 3 month old backups back every time C4D crashes or my old Mac has to reboot.

It’s pure terror on my email and me.

Working on a solution = new Mac.