ColladaLoader doesn't play Animation from r11


#1

Just wondering if anyone has exported an animated file to Collada .dae using r11 and tried to view the animation in ColladaLoader from the Khronos website? https://collada.org/mediawiki/index.php/ColladaLoader

I can view mesh, textures, cameras and lights however no animation will play. When I tried to view a animated Group, ColladaLoader kept crashing. The .dae has no reference to the 360 frame count in my C4D file either so it thinks there is only one frame. ColladaLoader uses 1.4.1 version same as r11.

I can view Max animated files exported via ColladaMax to .dae files fine in ColladaLoader, including Groups.

Also wondering if any beta guys know the reason r11 .dae files rename materials and objects with an ID rather than retaining their given descriptive names like ColladaMax does, as it makes locating items in the code difficult.

Edit: I am using the r11 saveable demo.


#2

Did you bake the animation before exporting?

firs thing I’d try is bringing the exported file back into cinema and see if anything is changed.


#3

Thanks Kai,

I had never actually Baked animations before so had to look up in the manual how to do it. I see now its purpose. The .dae now shows the keyframe details. I still doesn’t show the total frames or play in ColladaLoader but at least a step closer.

Given Collada is supposed to be the new universal format, it would be nice if all developers structured it the same. From Blender, Swift3D, Max, C4D the structures all differ. Anyhow thanks for the tip, I will keep investigating.

Edit: forgot to mention that the .dae played back fine when opened in C4D.


#4

I decided to pursue this a little more.

I exported a simple cube animation via Collada from C4D r11. It does not play in ColladaLoader whether the animation is baked or not.

I then decided to take the C4D .dae (unbaked) into Max. Everything views and plays fine. I then exported via ColladaMax without changing anything and the resulting .dae plays perfectly in ColladaLoader and Papervision3D.


#5

yes I’ve had similar experiences going form MAX to cinema. Using autodesk’s collada exporter I get the animation but the skin is broken in cinema. using a plugin one I got the skins in tact but the animation, while clearly in the file, does not load into cinema.

This is the problem with the flexible open format is the inconsistency.


#6

Well at least I can now assemble and animate my scenes in C4D too.

I sent Maxon support some files. Not sure they can do anything but sure would be nice to do the Collada to Papervision3D pipeline entirely in from C4D. Getting closer…


#7

Sorry to hijack the thread, I got a similar question. Is there an easier way to bake characters now? What I did until now was to cache with point cache and then use cappuccino to record the PLA onto the mesh.

Edit: That's odd... I'm trying to export and import an animation with collada, using PLA and a cube, and it doesn't do anything, it doesn't import the animation. I also tried baking it through the timeline (which doesn't work with characters), but when I import it stays as still as ever. Doesn't Collada support PLA?

Edit#2: I guess it doesn’t, as I see in the help file… So is mdd still the only practical way of exporting character animation? Cause it will probably be impossible to export everything of a complex character without using PLA, even if joints/weights import like they should into other programs which is a longshot.


#8

I’ve tried the same thing with the FBX converter. The animation is imported, the skin object is there but the weights are gone. This was a character animation from motionbuilder using joints.

I couldn’t import the jointed character directly into c4d. I created the animation then saved. Then converted to collada using the FBX utility and imported the collada into c4d.

Artzfx, how are you going from collada to papervision 3D?


#9

Hey Dan,

I was only just admiring your characters the other day from a post you made on a job thread.

At the moment ColladaMax plugin by Feeling Software http://www.feelingsoftware.com/content/view/65/79/lang,en/ seems to be the best solution for getting scenes into PV3D. Being a C4D user I really hope that changes so C4D can be used end to end.

A client of mine has built their own PV3D previewer using Flex/AIR. If I can play the .dae file in ColladaLoader I can pretty much play it in their PV3D previewer.

The issue with PV3D is it’s Z-sort issues, but I have a few methods to overcome most of them now.


#10

Hi,

Thanks, i’ve got more character work to show, but can’t figure out how to showcase more than 4 pics at a time in the portfolio. :slight_smile:

That’s awesome that your client has their own PV3d viewer. I’m going to check out the collada viewer too, it could help me out on a project i’m currently on.

I’d love to be able to use only c4d for this project. The client has me using 3d max with the same plugin you listed.

What kind of PV3d work are you doing? Do you do any coding? I’m only on the 3d modelling side of things, doing character work atm, but i’d love to get into coding sites. There are some amazing papervision sites out there.


#11

Collada Max was the plugin I was refering too actually,t he one that animation didn’t come into cinema from for some reason although clealry visible in the file in notepad++

PLA is not supported by cinema’s collada currently (not sure any other app does either), but depending on what your using it for PLA is not always an option. Personally for my needs PLA is all I need so I still am using MDD but I dont’ go to game engines and such.

On the baking front yes it has changed no need for any modules or workarounds just select the mesh, choose bake form the timeline and there is now a PLA option as well as expressions option, and the PLA can bake from deformations. This had to be done for the motion system to work, but it can be used for regular baking on just motion.


#12

Thanks Kai. Indeed Collada will prove very useful for games, I had just hoped it would also provide an all-in-one solution for exporting animation, meshes etc.
I too was looking if Collada supports PLA in general, but didn’t find a straight answer.

Now for the bake, I don't understand what I do wrong. I first tried with Flabio, and it wouldn't work, and then I tried with a simple cylinder and 2 bones, and I still can't bake it. I do a simple rotate animation on the middle joint, then select the mesh, hit bake object, check PLA on the bake window, but no keyframes are recorded to the mesh.

#13

51M0N,
Sorry I completely missed your first post. I haven’t dealt with PLA’s as yet so will leave Kai to help you with that.

DanB,
I actually saw your characters from a link you had on C4DPortal. I am making 3D web ads for them at the moment which is very different from building full blown walk through scenes for them with WPF/xaml. I am only on the 3D side of things too… I can sift through the .dae code and understand what it is doing but that is all. Some links you might find helpful:
http://www.madvertices.com/ - tutes, how to build a PV3D player by Jim Foley etc
http://blog.alternativaplatform.com/en/ - alternative PV3D engine - awesome
http://temp.roxik.com/datas/cloth/index.html - awesome samples including cloth and character/bones in PV3D
http://ecodazoo.com/ - one of the nicest PV3D scenes I have seen

Kai,
I received a very encouraging response from Maxon to my support ticket questions about Collada last night so sent them the scene files I have:
“COLLADA is like some other exchangeformats very multifunctional in it’s kind of object types and versions. We are still testing how it will work in exchange with other applications. The error can be in the COLLADA-Loader tool as well. Can you send me the original files (c4d, …) so we can compare the behaviour and tell me what version of 3dsmax you used?”


#14

Very cool! Thanks for the links. That last pv3d site is amazing. A great sign of things to come for the web.


#15

You have to pay :slight_smile:


#16

Oh too bad. Thanks.


#17

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.