Cinema 4D R21 Constraint Tag + Mixamo


#1

Hi all, I’m having a problem with the Constraint Tag in R21. I’ll try to explain it as good as I can since english is not my mother language.

So I have to do a few simple character animations for a work, basically i have to animate a character doing some “robotic” movements, so I have the character and I uploaded to Mixamo to get a quick rig done. Then I imported it as FBX in Cinema 4d R21 and using the new Mixamo Rig feature I just “re-rigged” the character to animate it. When I have the animation done I wanted to replace the head for another element ( I did this before with the Constraint tag and It worked in R20) but I can’t figure out how to do it now because I can’t target the “head” because when I started de animation I did it with the “built in” animation Rig in Cinema 4D not from the Mixamo rigs.

So to attach an element with constraint is really simple, I just put the object that i want to be attached in a new null and then apply the constraint tag to that null with the following settings:!

The problem is with the target, since I made the animation in the “built in” cinema 4d rig I can’t target the “Head” join because I can see it in the object browser only “Pelvis”. How can I target that join?

The problem is that the animation I made is “separate” from the Mixamo joins, I’m very lost right now. Should i start from scratch and instead of use Mixamo rig, rig the character by myself?

Thanks so much for your help!


#2

Try clicking on your Character Object, then select the Display tab in the Attributes Manager. Under this tab will be a drop down called Managers and under the Object Manager menu, select “Component Hierarchy”.

This will reveal all the individual joints that make up the rig in the Object Manager.


#3

Hi cmyk, thank you so much for your help, sadly still not working. I can see now all the joins but when I put the join in the constraint tag the object dont follow the join. Any other ideas what I’m doing wrong?

I’m getting nervous about this T_T


#4

You should put the Cabeza null AFTER the object that it’s constrained to in the object manager list, at the bottom of the list. See if that helps.


#5

Hi Decade, that what’s not the problem (I tried and didn’t work) the problem is that I’m a fckn dumbss and I put the wrong target, when I did the thing CMYK mentioned i saw what you can see in the picture, but there was ANOTHER target herarchy that was the correct one, not that one. So I just selected the wrong target because I didn’t know that the system made 2 different Hierarchy one is called “Retarget_Hierarchy” and the other one (the good one) its called “Bind Hierarchy”

So with the help of cmyk and your help we solved the problem.

Thank you both so much!


#6

Great, glad to hear you got it sorted.