Cinema 4D Grey viewport finally solved


I’m a long time 3D artist since the early 1990s, then retired in 2015, but recently was asked by an old client to recreate some of the 3D modeling of their construction products I did waaaay back then.

I still had the raw assets, but the software I used back then was Infini-D which ran on a OS 9 Macintosh.

I loaded up blender and got after it. The interface is wonky, but I discovered Cinema 4D, downloaded 2023.1.0 and it really reminded me of Infini-D. Was ready to render some test comps, when the viewport went blank grey, and nothing I did or clicked would fix it. Spent 2-3 days downloading drivers, changing filters, view settings and finding a million occurrences/suggestions on Google, but none worked… except one.

On the PC, open Device Manager. Select your graphics card. Disable it. Reopen C4D. Fixed. But then blender wouldn’t run. Re-enabled the graphics card, and they both work now.

Project done, Cinema trial lapsed. client happy!

Hope it helps someone