Cannot render out my cloner object within physical renderer


#1

Hello there, i have got another problem in C4D…

cannot render out my cloner object within physical renderer, can anybody help me please?


#2

Only if they’re clairvoyant…


#3

I am sorry for my misunderstanding but could you be more specific? Please


#4

This is precisely the advice you should heed when asking for help.

Only a clairvoyant can help you with you problem because you’ve posted zero information that would allow someone to help. There are no mind readers on this forum…


#5

It is just simple…

_ have got Cloner object which cloned few object primitives_
when i hit render within basic settings, i cannot see any of these were rendered out!

Need to say that this only happened when i use the physical engine… in standard it works…


#6

Why haven’t you posted your render settings or posted a scene-file? Why do you expect people to drag information out of you in order to help you?

If you are serious about getting assistance then provide as much information as humanly possible.


#7

bricks.c4d (15.5 MB)

Hello, i have already uploaded my file, you can download and see that there is problem about clones not been rendered with physical render. Please let me know what do you think, what is your advice.

I have worked within that file a while and found out that the problem seems to be with one “plain effector” i have applied on cloner just for hide few clonec within mograph selection. Is it a bug guys?


#8

It seems there is something wrong with the mograph selection tag. If you delete it, the scene is going to render the bricks.


#9

Within the plain effector you are scaling to 0 . Change that to any other value like -1 if you want to hide some

and it will render


#10

Hey there, thank you very much for your advice but…

See my file i have attached and have a look please. I found out it doesn’t work for me as you wrote. Please let me know.

Have a nice daybricks_v2.c4d (348.0 KB)


#11

this time you have to use -0.999 - selected clones will vanish and rest renders. Don´t ask me why, seems to be a problem with a 0 somewhere in connection with that selection tag. If any clone is scaled to absolute 0 all will follow. So just make these you don´t want to see small enough but not 0 :slight_smile:


#12

It does that trick! Thank you very much for your interesting research! :star_struck:


#13

Ahhh yes this has been a known bug with physical render. Clones cannot be scaled to 0 with an effector otherwise they will pop off completely as soon as the effector takes effect. This showed up maybe 4 releases ago. I guess Maxon never figured out how to fix it.

Scaling to 0 works fine in every other render engine Ive tried.