C4D, RealFlow, Krakatoa Render Problem


#1

Hey there,

I´m pretty new in the 3d World, so i have to fight some Problems cannot be solved only by using my Brain:-) In addition English isn`t my first Language…so, sorry for some mistakes.

My Problem isnt realy a Cinema 4d Problem but it is a Problem with the Plugins im Using in C4D I have created some Particles in Realflow, imported them in C4D with Krakatoa and everything works fine. But at the Moment Im adding a Gradient Channel to the Particles the Problem beginns. I´m able to render a single Frame but when i`m tying to render the whole timeline I always get the Message " Channel “Velocity” does not exist in the Source Stream"

I´m not shure if it`s a Problem with Krakatoa or Realflow.
When exporting the prt.files from Realflow I selected Veleocity in the “Export Central” under the “Particles Krakatoa” section.

So…please Help me…what am I doing wrong?


#2

I think you have a better chance posting this in the Thinkbox Forum Krakatoa for C4D subforum.

There are several possible causes for errors so we might need to check more closely in your case.

cheers

Daniel


#3

Yea thx,

but it seems almost nobody is using the thinkbox C4D Forum so i decided to ask my questions in a forum with a lot more users. In addition i am not shure if it is a Krakatoa problem. I have tested the same Render settings with Krakatoa internal particles and there was no Problem anymore.It must have somthing to do with theRealflow particle creation. I can give more information to anybody who`s interessted in solving this problem.


#4

I remember getting his error as well. But I don’t think it was a problem. If you map the velocity to color and see a result throughout the sequence, it’s probably fine.

W


#5

For what it’s worth I have been getting the same message when trying to render X-Particle simulations with velocity to color via the gradient Krakatoa channel tag. I assumed it was due to me using the XP3 beta but I guess it’s more of an issue with Krakatoa in general. I will move to the Thinkbox forums with this issue as well.


#6

insinde C4D, in your prt loader, under the tab “particle file”, there´s a tab down low saying “available channels”. what channel do you have there?
is there a “Velocity float32[3]” channel?
fuat


#7

Bobo replied to this issue over at the ThinkBox forum and said that the message is caused by Krakatoa trying to render a frame with 0 particles in the scene. The gradient tag is trying to access data that isn’t there. In order to work around this problem you have to use the Range Start in the PRT loader. Set the Range Start to the first frame that contains particles and then the Range End to the last frame you need rendered. I just did a test using this setup and it rendered the scene without any errors.


#9

This forum really isn’t monitored by anyone any more, is it?