A few UVW problems / questions


#1

Hello all,

I’m newish to C4D (but now 3D) and have a few problems/questions regarding UVWs in C4D (R19). I created a model, and then I made a UVW map for it. I created a material, and all was good. I then subdivided the model, and everything seemed to be working fine. I would do screen renders (render view) and everything seemed ok.

Next I copied the model, because I wanted to try different iterations. I added the subdivisions and everything seemed ok. I then subdivided one level higher (then previous version) on my render and the render came out bad (see attached). The top image shows my initial setting of 3 subd rendered, and then with a higher 4 subds is the lower image.

I went backwards to see what had happened, and it seems somewhere along the way my UVW map got ‘lost’. When I say lost, this is what I mean- When I select my base model, and then go to edge selection, the edges that were my cut edges for my map are no longer visibly selected. When I click on my UVW tag, the map still seems to be there but doesn’t seem to be linked to my model anymore. Basically I lost all connections between my object, the UVW map edges, and the UVW map.

Does anyone know why this is happening, and how to prevent it from happening? (meaning a way that I can duplicate models and have their corresponding UVW maps and tags all stay linked and together)

Is there a way to relink the UVW map with the model? If so, how?

I noticed one thing in the UVW tag that was not checked, and that was ‘lock UVW’. Does this have something to do with it? What does locking UVW do? And if it does link the map to the model, why is this something that needs to be checked, it should exist by default.

Lastly, if needed, this is a cutaway of a jaw model. The material is layered using alphas and the cutaway segment is a procedural displacement, if it makes any difference.

I’ve never worked with programs where the UVW map is ‘lost’ or ‘dropped’, and I’d like to know how I prevent this from happening. Any help would be appreciated.

Thanks for taking the time to read this. Please help!


#2

After playing around with the tags, etc. I was able to ‘fix’ things or at least make it work. I copied and pasted the UVW tag from an earlier version and it works now. Some other things I did:

1: I locked the UVW tag. Even from the info section I’m not sure what this does, and why things aren’t locked from the start.

2: I made sure the UVW tag was assigned to the same layer as the model. Believe it or not it’s possible to assign the UVW tag to a layer different than the model. Why this (different layer assignments) can be done is a mystery to me.

If anyone can explain any of the above, or what are best practices in keeping UVW tags together with the model I’d appreciate it.

And last addition…I moved the subdivided model order (reordered) in the model/object window and the problem came back. I then took the model out of the subd modifier, then put it back in and it rendered fine. Anyone else familiar with this bug?


#3

That is not a bug. When you subdivide an object AFTER it already has been UVMapped , you will need to adjust your UVs to account for the additional geometry.