YES! For all the people with newer NVIDIA GPUs:


#1

I finally found a fool-proof solution for all the people who have the selection issues and slow flat-shade modes.

There’s a little bit of fumbling around involved, but it’s well worth it.

What you have to do is this:

.) The thing is that this problem only affects newer Nvidia GPUs, I think it starts at the G71 chipset. And it only happens with the 9x.xx drivers and newer. So what we have to do is to change the 8x.xx driver, so that the driver is actually compatible with the newer GeForce GPUs as well. DO NOT try to let Windows just use the .inf files - your screen will go all funky and it’ll do you no good. My instructions:

  1. Download a 9x.xx driver from the Nvidia Homepage - I used 91.36. Also download the 84.26 driver from the Driver archive - or whatever 8x.xx driver you want, it should work with all of them. EXTRACT both of the .exe files to your Desktop. That’s important.

  2. Now I looked closer into WHY the 8x.xx drivers don’t work for my card. What Nvidia did was to create 2 files which specify Vendor and Device IDs for the GPUs - so the installer scans through the files and checks your card. If your card has one of the Vendor and Device IDs that those files specify, you’ll be able to install the driver. If not, it’ll pop up an incompatibility error.

  3. Open up the Modes.txt. I’m pretty sure that you don’t have to configure this one, but I did it nonetheless. Scroll down to the

[nv_SoftwareDeviceSettings]

part. Now, add the line for your card. You find the line for your card in the modes.txt of the extracted 9x.xx archive. For me, it was:

// 029C - NVIDIA Quadro FX 5500

Now, there are 2 brackets in front of the line, so it probably doesn’t matter whether you change this file or not, but I did it and everything works fine, so try it as well.

Here’s the important part:

a) Open up the NV4_DISP.inf file.

Scroll down to the [NVIDIA.Mfg] section.

There, again, you have to add a line for your card. For me, it was:

%NVIDIA_G71.DEV_029C.1% = nv4_WSApps_NV3x_DOEB, PCI\VEN_10DE&DEV_029C

You find the corresponding line for your card in the NV4_DISP.inf file of the extracted 9x.xx archive.

b) Scroll down again to ‘; Localizable Strings’ (without the quotes)

Add the name for your card. Mine was:

NVIDIA_G71.DEV_029C.1 = “NVIDIA Quadro FX 5500”

SAVE THE FILE.

Now, go ahead and install the 84.26 driver. It’ll scan the file and find the matching vendor and device IDs, so it won’t interrupt the installation because of incompatibility issues. The driver works fine, so don’t worry.

After that’s done, just reboot your machine and you’re all set:

Maya will work in Dual View Mode, Flat Shade is super-fast again and there are no selection issues, no lags, the artisan Brush is drawn the way it should and everything works just fine.

Granted, it’s a little painful at first, but it’s not as bad as it looks here. It’s just a long text, but it’s really easy to do. Nice!


#2

So this was done on a quadro, right? or did you do it on your 8800 and softmodded? I dont fully understand. Maybe i should give it a try as well to see if mudbox increases in performence.

Erik


#3

I hardware flashed a 7900gto to a QuadroFX 5500, but that doesn’t matter here.

The thing is that you can’t go back to 8x.xx drivers if your cards dev and ven IDs aren’t specified in the driver, which you can sorta ‘hack in’ - that’s what I’m describing here. Maya works wonderfully with the 8x.xx drivers, but makes a shit load of problems with the 9x.xx drivers (and the newer 1xx.xx drivers too). That’s what people have been moaning about here. Selection Lags, incredibly slow flat shade mode, etc.

Never change a running system. But if you have those exact problems, you should definitely go for it. It won’t hurt your card, you’re just using an older driver model.

Oh, btw: Maya isn’t the only app that slows down to a crawl using the 9x.xx (or newer) drivers. Wings3d will be unusable with them as well.


#4

well i have a 6800 +quadro mod, and I don’t have a problem installing the 8*.** drivers… but the selection delay issue when selecting in viewport while running in dualview has always been there when I’ve tried those drivers or any others. (Very annoying… sort it out nvidia/autodesk) Anyway I’m surprised it really is fixed for you by doing this… i’m doubtful to say the least, but I have a 8800 coming this week and I shall try reverting it to these older drivers and see if it really does make the difference. Failing that, I’ll try one last thing and that is using both 6800+8800 cards at the same time, each one driving its own screen. That way i’m not running any dualview mode. Hopefully they’ll play nice together and windows with each card treated as a seperate display adapter.


#5

Let me get this straight: You have the selection lag when using the 8x.xx drivers? That sounds really weird.

Also, you should read my post more clearly. It’s logical that you can install the 8x.xx drivers, since the dev and vendor IDs of your card are in the .inf file. Only people with newer chipsets that cannot install the 8x.xx drivers have to go through this.

(Very annoying… sort it out nvidia/autodesk) Anyway I’m surprised it really is fixed for you by doing this… i’m doubtful to say the least, but I have a 8800 coming this week and I shall try reverting it to these older drivers and see if it really does make the difference. Failing that, I’ll try one last thing and that is using both 6800+8800 cards at the same time, each one driving its own screen. That way i’m not running any dualview mode. Hopefully they’ll play nice together and windows with each card treated as a seperate display adapter.

Why are you surprised? It was logical for me. The 8x.xx always worked nicely when I was still using a 6800 it my workstation, so I figured they’d be nice with my new card too. From the 9x.xx on, those problems started to pop up - and not just in Maya, but also in Wings3d. I don’t use Wings anymore, so I don’t care about that, but having those selection and flat shade issues were a royal pain in the ass to me. Maya responds extremely quickly with the 8x.xx drives. Nice to see that the 9x.xx are ‘certified by Alias’ though, yuck.

It’d be really cool to know if the 8x.xx driver still work with 8800 cards - I do think they’d work if you’d add the dev and ven IDs to the inf file. It’s an older driver model, but I’m quite sure it’s still sending the same data around, mostly.


#6

Well i still have the flat shade issue, but other than that nothing fancy, some bugs in maya from now and then but it works most of the time. The only time selection time issues arrived is at work were i use dual screens, setting them as span works, though.

I want to know if i can get better performence in mudbox by doing something else, because right now i can like divde 300 000 polygons, then it will be a slowdown that isnt fun to deal with. Zbrush handles it much better then, but i want to work with mudbox, but i cant due to lag performence.

Erik


#7

Guys, please read more carefully. The selection issues and the flat shade issues only appear if:

  1. You have a newer Nvidia Card (G71 and newer)
  2. You’re using Dual Screens with Dual View (Horizontal Span works)
  3. You’re using 9x.xx (or newer) drivers.

So if you do have a newer card, if you do use dual screens and if you do use a newer driver model, you’ll most likely have to deal with the Selection Issues and slow Flat Shade Mode. The only solution is to step back to a 8x.xx driver and you can do that by using the method described above.

Erik: I wouldn’t know how to solve your problem. This is not a Mudbox Forum, head over to the official Mudbox forums or write the Skymatter Support a mail and ask them.

(Also, there have been tons of threads on the Mudbox boards about speed issues and how to work with higher polyCounts without your system slowing to a crawl, like using HardDrive caching and so on. The 8x.xx drivers certainly wouldn’t change anything for that matter.)


#8

I already told you i have a newer card and im using a laer driver than 9x.xx (160.03 actually) and i have flat shade issue still. whats the problem? I know this is not a mudbox forum, but it might be an similar issue there as it is in maya with flat shade.

And no, your solotion did not work. i tried 84.21 or something, and changed the files, it got me a bluescreen.

Erik

Edit. Sorry if i insulted your thread with mudbox talking, was just curious if you could help me with that as well but ok, i wont ask again.


#9

Hi,
I read your post, and it seems that you found a way to upgrade the GeFroce to Quadro.
My current VGA card is GeForce 8400 GS M - came with HP Pavilion laptop - and I was wondering if it is possible to change it to Quadro.
If the answer is yes, I would appreciate if you can tell me how to do so, and what is the equivilant Quadro to this model.


#10

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.