XSI - Graphics error, any idea?


#1

Hi all!

I’ve just re-installed my copy of XSI 7 after a long sabbatical in an academic version of 3DS Max, and I’ve encountered a very stange graphical error!

Here, for example, is a default chair that comes with XSI.

When I either maximize the viewport or shift to wireframe mode, I get the following error:

This affects all my models and even new scenes with created primatives. They either shoot off, like above, or simply disappear! I’ve got the latest version of my video card’s graphics drivers: I updated specifically to try to solve the problem - but to no avail!

I’d really appreciate it if someone could help me with this, I’m really at my wit’s end.
I own a ATi Radeon 9600, Intel p4 2.9 ghz, 1gb RAM.
This used to work with my old PC, all that has changed in a new motherboard and CPU.

Many thanks to anyone who can help.


#2

sounds like an s** old graphic card. (2003?)
assuming you already have the latest driver, try to set the environment variable
XSI_EMULATE_OPENGL=1.4


#3

Thanks for your help, much appreciated. I’ve edited the setenv.bat with the appropriate command you suggested but this hasn’t solved the situation. Is there a specific place within the .bat file that I must type the command into, and is there a way of checking whether opengl emulation is functioning once inside Softimage?

Thanks for your help.


#4

Get one of those drivers that turn your card into a FireGL.


#5

Did you check the antialias settings in your graphic card’s driver?

Check the Anti-Aliasing setting for your display driver. It should be set to Application Controlled.


#6

What happens if you reset camera® and reframe selection (f)


#7

Hirazi: I’ve already set my antialiasing to application controlled. Thanks for the input anyway. :slight_smile:

dwigfor: That doesn’t change anything, unfortunately.


#8

ATI card + XSI = Nothing but troubles.

Sorry mate, but get rid of that thing and get an nvidia based card. I know it’s not what you want to hear… but, well…

Good luck, hope you can get this sorted.


#9

really surprised this didn’t work! at the top of setenv.bat or in the windows control panel would be fine
set XSI_EMULATE_OPENGL=1.4
I don’t know how to check if it’s enabled


#10

Hi, I hadn’t included “set” into the command string. But I tried this today and there’s still no change in the operation of Softimage. I think, as 3dtutorial stated, that I may have to purchase a new graphics card. Luckily my ATi is an AGP card, and new card for that form factor are relatively inexpensive.

Thanks for all your help everyone. If anyone has any further suggestions, please post them.
Cheers! :smiley:


#11

Flash the card, as Bullit suggested. I guess you’re not going to loose anything by trying.
t


#12

He doesn’t need to flash the card. I did it with modded drivers for my Mobility Radeon 9700. He just needs to know what corresponding FireGL card is the 9600 when choosing the card to upgrade to.
Also there is an old thread here in CGsociety about modding a Radeon to a FireGL, he also can head to Guru3D Rivatuner board or if he puts a contact here he might get a present. :slight_smile:

It is better he also uses driversweeper http://www.guru3d.com/category/driversweeper/
to clean all remains of current drivers.


#13

Oooh, sounds promising, and I love presents! ------------ is my contact.
Thanks for the info, will look into it later. :smiley:


#14

You got mail.


#15

@Polycruncher - As it isn’t always a very good idea to make mail addresses public in forum threads like this, it might be a good idea to edit your last post to make the mail address disappear again…:wink:


#16

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.