XP 4, open VDB and Redshift?


#1

Sorry to be so dense, but how do you render an open vdb from xparticles in redshift?

I assume I use an rsVolume material using “density” in scatter and “temperature” in temperature?
Where does that material tag go? On the Xplosia FX object or on an OVDB mesher?

I can’t seem to get anything to render.

I added a light and set it’s contribution scale to 1 thinking that was the problem, but no.

I’m a big read the manual kind of advocate, but i’m not finding this info in the manual or the video tutorials from Insydium.

Thanks


#2

The shader goes on the Redshift Volume. Then I opened the Redshift shader and in the Scatter dropdown, I put the word ‘density’ in the Channel. Changed the tint to a grey color. Lower down on the Emission dropdown, I put the word ‘heat’ in the Channel. Changed the tint to an orange color and moved the Emission Remap Ramp to a setting I liked. That’s it how I got it to work… Good luck. The OVDB I used was with all the defaults when I cached it
Mark


#3

^ Beat me to it.

There are two types of VDBs:

  • Signed Distance Fields (SDFs) which are used for storing solid meshes (like liquid surfaces) that have an inside and an outside. This is the kind that the OVDB mesher works with.
  • Fog Volumes (smoke, fire, etc. ) this is the kind Xplosia generates when used with the Cache object.

#4

Oh, and one more thing I did. The Redshift documentation said that the light source must have the Contribution Scale set to 1.0 under the Volume tag.

Mark


#5

I used a dome light - but switched off ‘enable background’ - to leave me with a back bg, and left the tint in the RS Volume material at white.

I think the emission channel is typically labeled ‘temperature’. I don’t think the vdb’d that Luke posted in the other thread included a a temperature channel (correct me if I’m wrong Luke), but if you wanted to fake it you can enter ‘density’ into the emission channel as well and map that - typically to a black -red-yellow-white gradient.


#6

ahhhh…that’s what I was missing. I didn’t realize I needed to add a Redshift Volume. Thanks!


#7

100% correct. I wasn’t desiring an emission channel, so I decided not to cache it to save on space.