Wireframe, why can't max show it correctly?



I got this huge annoyance with the way max displays wireframe. If you’re viewing a mesh at an angle, the wireframe starts to flicker and even disappear. While working with some models some edges would disappear completely and cause a lot of pain figuring out if the edge was actually gone or just not showing. Here is an image portraying my problem:

As you can see after selecting a mesh the edge on the top left is completely gone and now I can’t tell if that’s an ngon or just a visual bug. Is this a problem with my computer setup or 3ds max in general? I tried in 2012 and 2013 and both have this problem.

The progressive display makes things a bit better but it’s weird in its own right. It seems to trace the existing edges with a lighter color on top. This is less than ideal to have colorful wireframe like that.

This is a problem only in Nitrous viewport. In DirectX the wireframe is fine but the actual viewport feels a lot slower and I quite enjoy the features Nitrous offers. And since switching the driver requires a restart and not just a button press I’d rather find a solution to this.

I come from Maya and there aren’t any problems with wireframe display at any angle so this is a new thing to me. Actually I don’t think I’ve seen such a thing in any other software.

Thanks a lot for your support.


I always assumed it was a graphics card thing, or monitor resolution setting giving the jaggies.


Its a while since I’ve fiddled with viewport settings as we have custom drivers here, but I’m pretty sure there is a option for turning on anti-aliased wireframes which may help…


I have NVIDIA GTX560Ti which is a good card and shouldn’t cause any problems unless it’s badly supported. The monitor is set to native 1080p resolution. And testing on my laptop which is 1336x768 the edge problems are present. The laptop has a totally different integrated ATI card of some sort.

For DX mode you can do that in driver configuration. For nitrous I can’t find such option. I tried searching but still couldn’t find anything. I don’t think it would help seeing as an edge is totally gone. It’s not about jagged lines, it’s about there not being lines at all or the lines being awfully broken.


I also have terrible display issues on both my machines- which are both running new gpu’s with latest drivers on HD monitors. Issues always occur the closer I get to the geometry. All verts displaying regardless of backface culling which is a complete disaster. All faces disappearing if your sub-object is deselected. Edges disappearing. Nitrous is very much beta and has been extremely buggy since it’s integration…how many years ago now…??


This is the z-bias for wireframe overlays being a bit wrong in Nitrous in Max 2013. It used to be a constant surprise whether it would be ok or miles out from version to version back in the day. Some versions would be pushed so far forwards they’d overlap the whole object. I was never sure whether it was the graphics cards I was using or max itself.

You might be able to improve it by playing with the manual viewport clipping. You can find that under the viewport label menu. Try pulling the far plane in nearer to limit the z range (pull the top marker down). You probably won’t be able to get away with pushing the near plane out any. Ideally the two markers should be as close together as possible to maximise Z precision.

It might not help any though. Some versions of max appear to ignore it.


Did you adjust the viewport clipping? If not, check out this video and try to play around with the clipping planes a bit. This could fix this sort of error.



Adjusting the clipping seems to make no difference on wireframe at all.
A bit on clipping, I find it a bit weird in max. In maya you could adjust clipping by simply entering numbers but in max it’s this mysterious slider with no info on how far the clipping actually is.


The slider is for viewport clipping only.
If you create a Camera for example, you will have numeric (and visible) clipping planes for every cam.

If it’s not the clipping planes causing the Problem, I would also guess that it is a driver problem.



Theoretically the viewport clip planes are automatic normally in max. It pushes them out to encompass the whole scene without you needing to change the viewport clipping settings yourself. You can see this by adding objects really far apart and see how they’re still visible, unlike Maya where you’d have to change the clip values for each camera yourself.

That’s the theory.

But in practice sometimes it’s not very good at it. Typically if the scene is very far from the origin or at an unexpected scene scale (if like us you work in metres then the near clip plane can be a bit far to get in close enough to work).

Normally you can just not worry about them, but I thought it might help here. I guess not though.


That’s what I feared. Because if it’s driver problem then there’s not much I can do.
I also suffer from a similar problem where wireframe would “push through” two sided objects like wine glass or bottle or anything that has something inside. This does seem like some zdepth problem but there doesn’t seem to be a way to adjust it.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.