Why OpenGL viewport performance never improve?


#1

This is frustrating… very frustrating.

Just ranting and making a bit noise hopeful people at Maxon take this seriously.

Please.


#2

in 99% of the cases the openGL performance in cinema4D is not the Problem. c4d can show single objects with millions of poys without problems. In most cases the reason for the viewport to lag is the CPU’s single core performace. The CPU needs to calculate all objects, deformers, splines, nurbs, xpressos and paricles.

If you need better viewport performace try to switch of everything you do not need.
I once made a plugin for that. I am not shure if it still works though because I didn’t use it recently.

best regards
Jops


#3

well here is the link anyway:


#4

Hi,
I totally understand your rant. I am having the same frustration with C4D. One thing that helps a lot, is disabling expressions.

This also means using plugins which makes use of expressions really slows things down.


#5

The article below helped me out when I had a massive project that got to the point where viewport playback ground to a halt. I have been using C4D a long time but was surprised to learn of some of the things that can cause playback to drag. The biggest thing for me ended up being a bit more organized (not my strong point) and using the Layers function to turn off unnecessary objects. I also found Cineversity’s CV Layer Comps plugin to be essential for quickly turning off and turning on everything within a given layer. CV-Mute Layers probably saved me a couple of days on that project all by itself.

http://www.mattfrodsham.com/c4d-scene-speed-index