Why do noise textures 'Fizz' in C4D?


Something I seem to see a lot in C4D renders, I’ve even seen it on interstitial clips on TV and thought ‘oh that must be a C4D shot’, is a sort of ‘fizzing’ in the texture when you use some procedural noise, say in the bump channel of a material, particularly if the object is animated or deforming.

Is there a way to fix this apart from baking the texture down to a map rather than keeping it procedural?



There is a black magic craft to getting rid of those aliasing issues sometimes…try playing with delta settings


Ive never noticed a “signature” fizzing like you describe. I use procedural noises fairly often for textured plastic on product shots. I find that the default bump settings are much too strong. I always need to dial the bump strength way down. Gary’s suggestion about turning the delta down in the noise is a good one.

Depending on how you apply your noise (texture space vs object space vs world space for example), the scale of the noise and your AA sampling settings i can imagine where you might get something like you describe.

Do you have a specific example you can point to? Now I’m curious :slight_smile:


Thanks guys, good to know it’s not just me in any case. I was hoping there was a simple ‘oh make sure you switch option x off in the noise’ solution but it doesn’t look like there is.

I’ll try those suggestions and any other suggestions very welcome though.

I do… but I’m not sure I can post it yet… asking for permission at the moment…



Ok, I got permission :slight_smile:

These clips aren’t part of the final animation, they were just quick cycles I did to test the rigs while building them but they illustrate the issue pretty clearly.

This one uses a texture for the bump and looks fine :
Good Clip

But this one uses procedural noise and has the fizzing I’m talking about.
Bad Clip

Notice how it almost looks like there’s a layer of old TV interference on his body as he moves? That’s the issue I’m concerned about.



I believe you can fix this in the Anti Aliasing settings. Changing the MIP scale can solve this.

What I do to avoid flicker is render my noise as a picture and then mapping that back into my texture using SAT mapping. Get’s rid of the flickers at really low AA settings too!

I also believe Physical is better at rendering noises noise free too.


The reason this is happening is because the default noise is generated in 3d space rather than in 2d (2d noise would have seams based on your UVs/projection type) As the object is deformed the polys move through 3D space and thus you get a ‘swimmy’ kinda look.

Just add a stick texture tag to the object with the noise material applied.

Alternatively, you could bake the 3D noise into a texture, but it’s not usually necessary.


The texture will be smoother for several reasons, the first is that the texture can use MIP mapping, a process where the image is automatically blurred when the object is far away or at a very steep angle to the camera, a blurred surface obviously wont fizz. The second is the sheer resolution, the noise shader effectively has infinite resolution, if you make the noise scale too small then the AA system often wont be able to cope with the abundance of detail, the texture on the other hand likely has a finite resolution such as 1024 or 2048.

To fix it:

  • Increase the noise scale or choose a pattern with less harsh details

  • Choose better AA (Best, 2x2 / 4x4 for example) Or lower the shading error threshold if using physical render

  • Check the noise is stuck to the surface with the right mapping, using a volumetric noise will also be a problem.


Awesome, many thanks guys, that helps clarify the issue indeed. Will test out on Monday and report back on which seems to work best in this case.



Another option is to choose a better AA filter for the texture itself. I prefer summation over mip.


Little personal anecdote around this. A few years back I had to animate a tablet device with a very fine mottled plastic back doing the usual slow spins. I tried dozens of tests, hiked up the AA, the bump delta, tried most of the noise types but couldn’t get get a stable looking result, the texture on the reverse just kept on swimming and fizzing. At the request of the client I gave VRay a shot, buying it on faith - and the difference was immediate, night and day. The very first test using the exact same noise settings as bump gave me a rock solid result, you could follow each pore as the device drifted around, it was pretty flawless.

Convert ever since. It’s this sampling and AA that was the big sell of VRay for me, it’s not an especially sexy feature but one that’s hard to live without once you’ve seen it. The GI, speed and lighting are nice side benefits :wink:

I’m sure C4D can do it, especially with the physical renderer, but at the very least it takes some fiddling.


I really doubt any of this has to do with his AA settings. If you look at his video, the one with a noise texture renders fine and without flicker.

Look at this; default noise applied to a deforming object:


The sphere on bottom has a stick texture tag.

EDIT: Looking again the whole object is rather noisy. So maybe not. Anyway I’d be interested in a render with no deformation, just a turnaround or something.


It’s not specific to C4D.

There’s a shoping list of possible causes :

  • Lack of stick texture tag

  • Accidentally have animation on in the noise

  • Too much small-scale, high-contrast detail in the texure, be it procedural noise or anything else. Consider changing ‘sampling’ from ‘MIP’ or introducing some blur offest/scale. (I think its this) Bear in mind the noise contains octaves of small details. You could even bake the texure to convert it to a bitmap if you want a quick - fire & forget solution.

  • Lack of samples in physical render or in standard render ‘bluriness’ samples.
    There’s a cruel dynamic in all render engines - that animation, as well as requiring of course, many more frame, also demands higher settings to avoid differences between frames.


Oh, another idea, copy your bump material, disable the bump channel and add a normalizer shader to the normal channel, paste your image into there. Can give better results.


All very helpfull solutions I didn’t know about, thanks guys!.

I also found another one, if all else fails, go for Sub-frame Motionblur. This will cancel out all noisy anomalies. I use it a lot to ‘smooth’ animated displacement maps, refractions and blurry reflections. Used to work on QMC too but not since R13.


world space vs. object space vs. texture space


Some of these techniques I knew about—most I didn’t. Utterly awesome thread guys! Huge kudos to all.

My root-beer in toast: :beer:


Just to reply to this - thanks again for all of the suggested solutions.

Unfortunately I can’t give a definitive answer as to which one fixed the issue as I wasn’t the person handling the rendering on this job but they told me that a combination of various suggestions here all seemed to help and improved the final result. The job is in the render farm as I speak and we should have a fun little short to show off sometime next week :slight_smile:

Thanks to Chris for taking a look at the file too, via Olly.



Wow 2015! And still that shit happens? I’ve been facing it on Corona Renderer also. Small procedural noise fizzes!

Did a quick test in RS and it goes smooth like butter!

Any improvements back now in 2022?