whats wrong with this picture?


i have a dome of point lights with specular off and depth shadows.
And one parallel light with depth shadows
the cube is just a regular cube but scaled in 1 direction to make it longer.
there is a render tag on the foor to receive shadows but not cast them. i put a rendertag on the box with everything checked except compositing background.
any ideas why this is happening. its like the parralel light doesnt know i scaled it. but the point lights seem to have no problem.
btw i have c4d ce Thanks


heres another image. the render i did in hte viewport isnt as washed out by light as the render i did in the picture window. I didnt change anything i rendered 1 right after the other. i dont know what i am doing wrong. the light is set to 20% brightness. but for somereason when i render in the picture windows its coming out brighter. its a distant light if that matters with no shadows set. ugh this is frustrating.


can you post some files, hard to figure out what the bug might be without a file to check.


You need to increase the parallel width of your parallel light’s shadow. In C4D 7 it’s in the Shadow tab of the Light setting dialogue box (not sure about CE).


yeah that´s the solution in xl6 so i assume it will also help within 6ce.


na it didnt seem to work. I changed it to 1000 instead of 100 and still didnt work. heres my file btw

can you also see why when i render in the viewer it takes my light settings but when i render animation in picture viewer it doesnt show a shadow or like in my second post it rendered at full brightness even though it was at 20%. i dont know what i am doing wrong.


aha file helps a lto I had no trouble fixing your odd shadow bug, in the shadow tab, just above shadow outline checkbox there is a parallel width setting, I set it to 1500 and no problems it renders as expected.

As for the odd no shadow or brightness issue you mention between the viewport and thepicture viewer, I can’t seem to recreate in 8.2 so perhaps its a CE only bug :confused: I’d send it directly to maxon as a bug report.


well like it posted already i tried the 1000 and it didnt seem to get any wider and put 1500 like you state and no go. i even tried 15000 and nope. i guess thats another bug. Can anyone with Ce try it out. ill try and delete the light and put another and see what happens. Thanks for your help.

i think its just a problem with parallel and distant lights becuase with omni and spot light i have no problem with the width of the shadow.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.