Weird non-manifolds with polygon pen


#1

Hello, all. I hope, you can help me with this.

I´ve never modeled with the mesh check enabled but because of a job modeling a house for use in Unreal Engine, I´ve decided to set in on. Bad decision… very bad, because of this …um… bug (?) is driving me crazy. Is it a bug or just me?!?

This is a simple wall, made from a converted cube with cutted edges for the doors and windows. To make a wall integrated balcony, deleted the frontside polygons. Before I´ve extruded I closed the hole between front and backside with the poygon pen (auto weld on and also tried it after the extrude). But then… here they are. non-manifold red lines…

I´ve checked anything after hidden polygons or not connected points… and found this: the backside connection has two edges but also only two points… Shouldn´t it be four points in case of not connected poylgons or one edge in case of nicely connected polygons in love… without any red flagged non-manifold geometries?!?

See images.

1: No hidden geometry

2: Here we are.

3: One edge at the frontside (Yeah!!!)

  1. Backside two edges

  1. But only one point here…

  1. …and one lonely point there.

I very appreciate your help.

thanks in advance


#2

when you are selecting stuff trying to figure this out do you have “only select visible…” unchecked? If 2 points/polys/edges are in the same place, only one will be selected if “only select visible” is checked

and have you also selected all the polys and chosen “optimize”?

and also, have you selected all of the polys and checked which way the normals are facing?


#3
  1. Yep
  2. also yep
  3. yep too

I think I´ve tried all possible variants to exclude any user-failure… but you never know.


#4

Maybe I’m way off base, but, an easier method would be to extrude the wall with
a spline built in c4d (Ai,etc).

Here’s a simple example:


#5

Non-Manifold means an edge is being shared by more than one polygon.
In general you want to avoid them, if you delete the single sided poly filling the window, they will return to nominal edges.

If you want a one-poly thick window area, I would disconnect those polys or split it from that mesh completely

cheers,
brasc


#6

Thank´s for this tip, David. That´s a good allternative but unfortunatelly in this case not. .-) Because of two reasons. One is that it´s a little bit more work when you model a building after a given architectural floorplan. The second is, this method makes unwanted slices from corner to corner like the boolean method. I did not have good experiences with that for working in Unreal Engine.


#7

Hi, brasc. Thanks for your that. That explained a lot for me. There are three polygons sharing one edge.That´s my problem with the balcony and at the doors area… I will split the balcony from the wall. But it´s not necessary for the window areas. There are no non-manifolds. See here:

Again thanks a lot for that. Now I can sleep again .-)