Vray - Ptex - DR materialproblems


#1

Hey guys, just encountered another problem: I used Mari/Ptex to paint my geometry before rendering it in Maya/Vray. Local rendering looks perfect, but when it comes to distributed rendering it looks like this:
http://tinypic.com/r/2yzh8p1/6

Parts of the textures and materials wont show up. I assume it has something to do with UNC paths, but I dont really know how to set this up. Can somebody give me a quick step by step?

Workstation:
Windows Vista

Nodes run on different OS, mostly Ubuntu. Some have Vista/XP, two of them MACOSX.

Thanks guys!


#2

make sure you’re running one of the newer nightly builds. They transfer assets correctly and you can mix platforms no problem – older builds have problems or just don’t transfer assets automatically (you have to mirror absolute paths). What you’re seeing is probably just the asset not transferring, although I haven’t tried it with Ptex. Disable cached assets though, since there are still bugs with that. I’m using the latest Windows / Linux builds with the Mac build from Sept 19. The newer Mac builds have a bug that affects DR so they are just finishing the fix but I’m rendering fine between OS X host/Windows and CentOS slaves.


#3

Thanks for your answer! I’m a student and got a Vray-EDU-License, is it possible to get a nightly build with that license? If so, where can I get it?


#4

contact Chaos Group via their web site and tell them that you’re in need of mixed OS rendering features and so you want to know if you can have access to the nightly builds. They will send you an URL and password. I don’t think they will care that you’re using an edu license.


#5

Sadly they do care :frowning:

“Please notice that we do not provide nightly builds to the EDU licenses. Nightly builds are provided to commercial users only.”

Anything else I can do to get this to work?


#6

well, you could get it working with properly mirrored share paths and SMB. Read my blog post here. Note that this only works between Linux and/or OS X machines since Windows has a completely different absolute path structure (you can’t fake /Volumes/STOCK/ from C:\Volumes\STOCK):

http://polygonspixelsandpaint.tumblr.com/post/25437127142


#7

Many thanks again. I solved the problem, including the windows-nodes.

Created a shared directory on my first Ubuntu-Node and copied all textures, materials and ptex-files to this location, and mounted it as a networkdrive on all nodes.

I changed the assetspath on my OSX and Linuxnodes to the said location:

export VRAY_ASSETS_PATH=/[SOME]/[PATH]:/[ANOTHER]/[PATH]

at this point OSX and Linuxnodes did it already right.

Changing the environment variables on the windows nodes alone didn’t do anything:

Click on “Computer” (Vista) -> properties -> advanced system preferences -> environment variables.

Add a new one and name it “VRAY_ASSETS_PATH”

Now, entering the exact location of the mounted drive won’t do it. You have to use UNC-paths: \192.168.2.XXX[path];\192.168.2.XXX[anotherpath]

Thats it. My renderfarm is now fully operational and does contain 4x Windowsnodes, 2 OSXnodes, 4 Linuxnodes (3x Ubuntu, 1x Fedora) - 30 Threads in total.

Thank you very much again!


#8

wow - nice work.


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.