Vray MaxObject?! vr.filter_kernel


Im making a script here and trying to interact with Vray’s settings via a script VS flipping through tabs. I’ve hit a wall in one area here when I try to modifiy the filter type in max. According to the Vray Maxscript cocumentation, the filter type is in the classof Maxobject (not entirely sure if thats important)

renderers.current = V_Ray_DEMO_1_50_SP2()

when I type in “vr.filter_kernel” that points to the A.A. filter currently active in Vray and returns something like Area:(null) , or Mitchell-Netravali:(null) depending on the active filter. I tried to modify the filter used via script without sucess. I tried:

vr.filter_kernel = Mitchell-Netravali:(null)
vr.filter_kernel = Area:(null)
vr.filter_kernel = Mitchell-Netravali
vr.filter_kernel = (Mitchell-Netravali:(null))
vr.filter_kernel = Mitchell-Netravali[1]
etc etc etc and I keep getting the same error message "
– Unable to convert: Area to type: MaxObject

Im starting to wonder if this is a “read only” type thing. Any help would be apreciated. How can I change the filter_kernel via script, OR how can I figure out if what Im looking at might be read only or not?


presuming you can assign it, I think you’d want to try…

vr.filter_kernel = Area()

‘Area’ is the classname of the filter, ‘Area()’ actually constructs an instance of the filter that you could then potentially work with.


Thank You!!! I could have sworn I tried that!!! Im just glad the search for figuring that out is over, thank you so much for your help, that worked like a charm.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.