Viewport visibility weirdness


#1

Hey All,

Wondered if this is happening to anyone else.
I’m working on a project where I need to align maps (geographic kind) in the viewport but placing one map above another in Y so I can scale and adjust position to match the one below.
Sometimes it works fine. Other times, I have to move the map above 5 cm in Y to make it visible above the map at 0 Y. My viewport sometimes will allow x-ray to work and other times not.

You’d think a plane with an image, placed at .01 cm in Y would be visible over a plane at 0Y but it doesn’t work.

Could it be a software bug or am I doing something silly?

Thanks,

Using the standard renderer, level of detail high, windows 10


#2

I’m confused, could you share some screenshots depicting your problem ?


#3

With .01 a plane will artifact somewhat in the viewport … but renders fine.
Placing a second plane at .o5 will not artifact and renders fine as well.

Putting the top plane in xray at .01 will appear below base plane at 0 …
but, renders fine.


#4

Thanks guys,

Here’s an example: Small map (Yellow) is at -1cm in Y (World)
Larger map is at 0cm in Y.

X-ray in viewport is OFF. X-ray in object attributes is OFF.

I shouldn’t be able to see the smaller map if it’s physically below the larger one?

Here’s another issue. Spline with an extrude modifer (NGon). Extrude and spline at 2cm in Y and I get this distortion?

I wonder if it’s a viewport setting or a video card issue? (NVIDIA GeForce RTX 2070 Super)
Drivers up to date…


#5

It’s a precision thing.

If you don’t work with perspective you can place objects with greater distance from each other and render with the orthogonal camera without seeing those artefacts.


#6

Yup. If I switch camera mode to Isometric (If that’s what you meant by Orthogonal Camera), it fixes the issue.
Definitely something to do with camera perspective.


#7

Yes, I meant Isometric.


#8

I still don’t understand what the issue is by using Perspective camera settings.
Surely this should be ‘precise’ too?


#9

I think it’s an OpenGL issue.


#10

Well thanks for the input Demis. Appreciate it.


#11

is this not just the document->viewport clipping?

i.e. reduce the far value, or increase the near value, etc.

best
Paul


#12

And the winner is…

VIEWPORT CLIPPING!

I’d unintentionally scaled up my scene to match the large res images I was using.
My scene was huge. Changing the viewport clipping solved the problem.

Thanks for everyone for their time and input in helping me not be such a dummy.
Stay safe out there!


#13

Where is all that ?
You mean Project -> View Clipping ?

I thought that was a camera/object setting and the problem was a between objects clipping thing…
Haven’t noticed there was a near/far user input either …

good to know, cause I had a clipping problem in the past when dealing with a 3D printed model in the mm scale and setting it to Tiny didn’t help.


#14

Ctrl+D to bring up Project settings.
As well as the standard dropdown viewport clipping (Tiny/Small/Medium/Large/Huge)
There’s a dropdown arrow that allows you to manually enter amounts.

Fixed my issue. See image: