Viewport only updating on mouse up.


#1

I’ve been getting a strange issue lately where my viewport only updates when I release the mouse button. Frustratingly it’s intermittent, sometimes solving itself, sometimes needing a restart (of the app or PC).

It happens on very simple scenes, even a single cube.
It happens in wireframe, gouraud shading and everything in between.
I can’t think of what may have caused it, I don’t think I’d updated anything (C4D, drivers, OS) when it started.
I’ve tried:
Updating my graphics card drivers (clean install)
Both graphics cards.
All sorts of OpenGL and display settings in C4D.
Houdini is fine so it’s not system wide.

Not sure what else to do? Any ideas would be appreciated, it’s driving me mad.

I’m using: Windows 7, C4D R19, HP Z840, GTX 980Ti, Quadro K4200.


#2

Hi, I am experiencing the same problem (DELL Precision 5810 with 2 x Quadro M4000 here) and my partial solution is using driver 386.28 which is the only one that seems to have no problems with Cinema4D.
I hope someone else has an idea of why this is happening and how to solve it.
Michele


#3

I have the same issue on a K5000 and I am pretty sure it has to do with NVIDIAS driver optimizations for c4d with their Quadro drivers. Unsigning the c4d.exe resolved the issue so the driver doesn’t detect c4d and doesn’t run the app specific optimizations. That of course costs performance, because the optimizations are usually there for a reason.


#4

Thanks for the replies, at least I’m not going completely crazy.

How do I unsign c4d, I’ve done a search but it’s not something I am familiar with?

I’ll look at rolling back to 386.28.

Thanks again.


#5

It’s not something, that I would recommend doing, but if the driver rollback doesn’t help:

Get FileUnsigner (Google it).
Copy original cinema executable.
Use file unsigner like in the instructions of the tool.
???
Profit

Programs have digital certificates that are used by drivers to choose a fitting custom setting. If you remove that, the driver will run with default settings.


#6

Thank you.

I’ve rolled back to 385.69 and it seems to have fixed the issue.
My machine wouldn’t let me install 386.28 as Michele suggested so I went with the one before.

Thanks again for the help.