Viewport Navigation/Interface has Completely Wigged Out


#1

This seems to be a system issue rather than a C4D issue. But I’m only experiencing it in C4D (multiple versions of C4D), and it’s persisted even after resetting my C4D preferences, rebooting, etc. However, I’m not experiencing anything odd in any other part of my Windows workstation or in any toher program.

What exactly is happening?

  • If I left click in the viewport and move my mouse, my camera pushes in and out. Or the object I’ve selected increases/decreases in size. Not sure why.
  • This means I can’t select or move handles. My camera just dollies when I try to, or the object changes size.
  • If I right click in the viewport, sometimes my camera rolls on the B axis. Or it dollies in and out. Or the object increases in size. I can’t do anything in the viewport that doesn’t mess something up.
  • I can’t select keyframes in the Timeline. My timeline zooms in and out, or the playhead moves back and forth as if I’m holding the J key. But I’m not. If I jam the J key hard, the symptoms change, but they don’t get fixed.
  • I can’t click/drag selection boxes in the timeline (at least some of the time). Again the symptoms keep changing if I whack different keys.

It’s as if some of my keyboard keys are sticking, but I just typed a whole essay in Microsoft word without any issues whatsoever. I can use/navigate Houdini as well without any problem.

If I reboot my workstation, things are ok for a short bit, and then it all wigs out again. I tried opening an older version of Cinema, and the same things occurred immediately.

I am at a complete loss, and I can’t get squat done for work.

Thoughts?

Thanks,
Luke


#2

Something similar happened to my wife’s computer a while ago.
A particular application went completely unusable, not responding to mouse or keyboard actions, or doing completely opposite things. Other applications didn’t have any issues.
Rebooting a few times, even ran a full virus scan to see the system wasn’t infected in some way. Nothing seemed to help.
In the end, we found the problem to be a shift or control key that got stuck somehow. Being a low profile keyboard, the pressed / depressed state of the key wasn’t noticeable.
Freeing the key from its permanent pressed state, and all things returned behaving normally.


#3

Do you have Quadros? The latest driver updates messed up a few things a few threads down.


#4

That sounds like the old ghost in the machine bug coming back to haunt you. For the last… forever years, there has been a very rare, hard to reproduce bug in c4d where a ghost keyboard key gets stuck and causes certain behaviours. Usually this shows up as getting stuck in the scale tool, being unable to select objects and just other odd click and drag behaviour. Reloading c4d won’t fix it, rebooting often won’t fix it, only a full power off/on cycle stops it from happening.

Might be worth updating keyboard and mouse drivers/hotkey software when you’re done. Do you happen to have any extra input devices attached? wacoms, Bluetooth inputs, accessibility extensions, keyboard/mouse sharing apps etc.


#5

My workstations are possessed, so this doesn’t surprise me.

My current theory (which so far seems to be correct) is that when my anti-virus software recently “upgraded” itself without my permission, the latest version believed my Apple keyboard to be infected with malware - I received a weird warning, and specifically told the system “No, this isn’t a suspicious device”, but I think it sparked some bizarre behavior. I uninstalled the anti-virus, and things appear to be smooth again… [i]for the time being.

[/i]Now I’ll stare at my keyboard each day and wonder if there’s malware inside.

(As for graphics cards - I have a GTX 760)

Thanks for the help everyone!


#6

Which virus checker? Personally I’ve had this bug happen to me 3-4 times over the past 20 years, but not in the past 10 years or so (though I know it does happen to others) This would roughly coincide with when I stopped using virus checkers. The only checkers I used were the free ones, avg, Avast etc.


#7

I was using Sophos. They upgraded me to their new Professional/Premium edition for a 30 day trial without my permission.


#8

I’ve been experiencing some weirdness the past couple of days and wonder if it’s a similar bit of voodoo or if I’m simply doing something wrong (I’m quite the newbie).

Using the 1, 2 and 3 keys to pan / zoom / dolly in combination with a Wacom tablet works fine. Until it doesn’t. Periodically, with steps I can’t reproduce, the 1 will simply quit working. 2 and 3 continue as normal, but holding 1 no longer pans. Similar to the OP, I brought up notepad to type the numbers in case my much abused keyboard was sticking, but nothing abnormal there.

When this happens, there’s also a small white dot in the center of the viewport, which makes me wonder if I’ve simply done something stupid and invoked some kind of mode that overrides 1 but not 2 and 3.

Do I need an exorcist, or just an education?


#9

The white dot suggests you may be viewing the scene through a camera, which might cause some of the issues. In your viewport, try clicking on Cameras --> Use Camera and shift to “Default Camera” if its not already selected.

If that doesn’t fix it, bring up the Commander, and type in “Camera”. Click the one shown here:

Now go to your Coordinates tab, and zero out your rotation values.

Sometimes my default camera gets inverted, and weird things start to happen. Zeroing out occasionally fixes it.


#10

Hey, Luke.

Great stuff, thanks for taking the time to be so detailed. I suspect that’s exactly what I was experiencing.

I’ve been trying to get used to using the Wacom when working with C4D. It still feels clumsy, so I probably kept making pen related typos as I worked. Yesterday I was using the mouse instead and didn’t encounter it. When I go back to using the pen now I’ll know what to look for if I screw things up again.


#11

I haven’t used a Wacom with C4D before, so I can’t help you there. Hopefully this was it!