Viewport background weirdity


#1

I’ve just changed over from Maya to Max 5 and am whizzing through the start of the basic tutorials. For the tutorial on basic modelling which creates some chess pieces you have to model the knight. At the start of this tutorial it instructs you to set up a viewport background image. Sounds straightforward…

I followed the intructions to switch on the viewport background in the left view. On the dialog I selected the file, set it to match bitmap aspect and Lock/pan zoom. The display background flag here is on by default. I pressed ok and bingo…nothing.

On the viewport menu the background is ticked on and the settings in the viewport dialog are still set as described above.

I checked through prefs, UI settings etc but couldn’t find anything to make the background show up. I had almost consigned it to being a bug until I loaded up one of the finished tutorial files for the object. Who would have thought it… The background image in the file works fine. I checked the Viewpoort background settings and they are the same as mine…don’t figure.

Even more bizarrely, after loading the tutorial example, I reset from the file menu and tried to set up the background… bingo in the right way this time. It worked without problem.

Unfortunately, after I quit and load up a fresh I can’t get the viewport to display a background again. It’s not that important to me but I am pulling my hair out in sheer frustration.

As it is, at the moment I can get the background to work in the viewport…but only after loading the knight tutorial and then resetting. Bugger.

Any ideas would be much appreciated. I was just getting to really like this move to Max as well. Hopefully this is an easy one for the veterans out there.


#2

Which display driver are you using (preferences, viewports)?

Software (heidi)

OpenGL

Direct X…

Backup your 3dsmax.ini file and try a different display driver. If max displays funky after restart you can at least get back with the saved .ini file.

-Shea
www.Ls3D.com

:cool:


#3

It was something to do with a display bug after all… Turns out that when the background doesn’t appear all I had to do was draw 1 object and bingo, everything was ok. I spent ages on this…bugger…I probably won’t even use the feature that much. Thanks for the pointers though.


#4

Hi, hope someone can help an enthusiastic noob…

I have been having problems with the size / scale of the image I try to set as my background.

If I select the option in views > viewport background about Aspect Ratio, I check ‘Match Vieport’ and the image has been squashed, if i check ‘Match Bitmap’ then not all of the image is displayed in the selected viewport but the pic is at the right proportions at least.

Is it possible to move your vieport background or make it fit better, or lock it to the centre of your grid / axis? I just dunno :frowning:

Any help would be massively appreciated as i am a noob, as you can prolly tell from my post count :stuck_out_tongue: But I have read a great many tutorials and have recently started trying things out :slight_smile:


#5

just make a plane the same size as the image you want, and save the image and apply that to the plane as the texture and hit show map in viewport…its much easier. I’ve never tried making the whole background an image…whats the difference? Is it better quality or something?


#6

If I knew how to texture yet then I would, sounds like an excellent idea. However I don’t :frowning: so i can’t :frowning: Nevermind, thanks for the suggestion. I’m sure it’ll come in useful when I have progressed a bit more :thumbsup:


#7

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.