Viewport 2.0 not working in 2018


#1

I’m trying to build a face rig in maya 2018 and viewport 2.0 is not working at all. If I switch back to the legacy viewport everything works great, although a little slower.

I have a character skinned to joints with a control rig and I have a the head mesh duplicated off a few times and skinned with joints for the face controls.
These duplicates are then connected back to the main rig with blendshapes.

When I animation the joints on these duplicated meshes, they deform correctly, but the blendshape they are driving wont update half the time. It will when I am moving the control, but adding keyframes and scrubbing the timeline is hit or miss. sometimes it updates, but most of the time the blenshape only updates some of the verts.

I know viewport 2.0 has problems and can be reset with ogs -reset but unfortunately that isn’t working this time.

Any thoughts on why viewport 2.0 wont update but the legacy viewport is fine?


#2

If you are still using Maya you are shooting yourself in the foot. If you are using Viewport 2.0 you are shooting yourself in the head. Bake everything and perhaps then Viewport 2.0 will work.


#3

Considering Maya is industry standard for animation, that wasn’t a very helpful reply.


#4

There are far too many thing in Maya that it is impossible to be helpful with. Viewport 2.0 being one of them. It is what it is. If you rely on it you are painting yourself into a very tight corner. As far as Maya being an “industry standard”, today, that is very very questionable. Gone are those days. Unfortunately. Nothing lasts for ever. Not without some effort from the company that is responsible for the development of Maya. Good luck with your project. Maya is not what it is used to be. You don’t need me to point it out. I am sure you know.


#5

Do you have a repro scene.?
Are you on maya 2018.3.?


#6

Are you using OpenGL or DirectX for your Viewport2 driver?

I had to switch to OpenGL to get Vray shaders to work in the Viewport (Maya 2015) for example. Try switching to the one you’re not using?

And ignore that Nick guy. He’s useless.


#7

Thanks for the complement. Made my day.


#8

Nick, don’t hijack other people’s threads because you want to bitch about Maya. Start another thread so people can ignore it.

Gnimm: Try turning off “GPU Override” in settings. It still tends to cause a lot of problems.


#9

I wasn’t trying to hijack anything. I was merely pointing out something that you all perhaps did not know. Using Viewport 2.0 or parallel evaluation or Maya for that matter you are setting yourself up for a not so “creative” session. You will be wasting most of your time troubleshooting a dead horse to put it simply. If you already knew that than please go right ahead and do whatever you were doing. Don’t let me slow you down. That is what Maya is for. Just trying to help.


#10

You’re not contributing or helping anything. You just want to bitch and moan. That’s fine, but do it in your own thread, not in one where someone’s actually trying to solve a problem.


#11

Other things to try are disabling the Caching options in VP2.0 as they only affect that mode so might be a factor, or try disabling Parallel Evaluation altogether and revert to DG mode if it’s not playing nice with your rig. There are some update changes/issues with hidden meshes in 2018 so that might be a factor.

And yeah, ignore the negativity… Maya 2019 will be the best release for animators in years.

Cheers,
Brian


#12

How how do you know that? You make us sick…


#13

Thanks for the replies.

I’ve tried everything I can think of as well as all the suggestions here and even gone as far as to re-design the rig to remove all constraints and keep everything to direct connections, but nothing will fix the rig in Viewport 2.0 running in Parallel.

Switching to Serial seems to fix things as well as using the legacy viewport, so for now I will just use that and hope we get a few bug fixes in 2019.


#14

(Two trolls in one thread? Really, guys.)

There’s no point hoping for bug fixes if you haven’t figured out the problem and reported a bug–they can’t fix bugs they don’t know about. Did you disable GPU override? That’s the only viewport-related feature that tends to cause “rig not updating” issues in my experience. Also, check the output window for errors, since that’s where viewport and OpenCL logs go.


#15

Because I’ve been animating in the beta version for about 3 months now. It’s a beautiful thing.

Cheers,
Brian


#16

Yeah, there are some documents on the AD site on best practices for making rigs ‘Parallel Evaluation Friendly’ but they can be quite complex… sometimes the simplest fix is just to go back to DG mode and get the job done :wink:

Cheers,
Brian


#17

Another critical thing is to try the rig in an older Viewport 2 design, to isolate which version it’s not working well in. Try it in 2017, 2016, or 2015 if you can. That’s the kind of stuff that helps things get fixed faster. If you don’t have access to older versions, ask around.