Very Slow Material Preview Update C4D r20.059


#1

Hello to everybody I attached a video to clarify what is my problem, I don’t know how to fix the material preview, run faster because it is insane the time who takes make some adjustment, thank you for your help in advance!!


#2

You haven’t attached any video so I can see the problem, but problems like this are usually because there is a texture you have linked to that has either changed location (i.e. missing), the location is inaccessible or slow (like a network drive for instance) or the texture size itself is (usually) unnecessarily large.

Links can be checked and fixed by going to the Material Panel and going to Texture>Texture Manager…

Alternatively, place all textures/images in a “tex” folder in the same folder as your .c4d file and relink them using Texture Manager as above.

If it’s just a single project or material that acts like this as opposed to all projects and materials, then the above will probably be the issue.


#3

Hi Drew, thank you for your help well I couldn’t submit the screen recorder since I am new here and I need to wait. But I dont have any texture is just reflectance and just that


#4


#5

when I move some parameters I need to wait like 20 seg and a red square is around the viewer


#6

Is it all projects and materials that are so slow or just a specific project and material?

You haven’t given much detail to try and help you work out the problem unfortunately. I don’t know if you’re on PC or Mac or what machine specifications you are working with.

Check if you’re using Hardware Open GL in Preferences>OpenGL and Hardware OpenGL is ticked.

If it’s just a simple material without any textures and taking so long to refresh and any material or project, something is may be wrong with your computer you’re using either hardware (CPU/GPU/RAM) are not up to required specification or faulty or possibly drivers for graphics card need updating.

Another suggestion is to reset your Preferences in Cinema 4D. To do this, go to Preferences (Ctrl (Cmd)+E) then click Open Preferences Folder, close Cinema 4D, delete the folder called prefs, then restart Cinema 4D. This will make all settings default so you will lose anything you’ve configured as custom.