V-Ray Caustics preventing direct light from passing through windows?


#1

Hey everyone!
I’ve entered into the realm of V-Ray and have been trying to make my first realistic render.
Unfortunately, I’ve run into a little snag.

I’m using a Simple VRaySun and Sky lighting with an HDRI mapped to the environment. Primary bounces are set to Irradiance Map and secondary are set to Light Cache.

Everything seems fine, until I turn on Caustics. I’ll let the pictures speak for themselves:

Caustics off:
[spoiler][/spoiler]

Caustics on:
[spoiler][/spoiler]

(Note: These are rendered at low quality for preview purposes, but cranking up the Irradiance map and light cache settings has no effect on this issue).

As you can see, the light from the VRaySun no longer penetrates the window panes. The material applied to them is a regular glass one (completely transparent with an IOR of 1.6), but the glass is 2.5mm thick - hardly enough to distort the light so much that it wouldn’t pass through the glass entirely. You can even see how little it actually refracts the light through the open window.

I’ve tried fiddling with the caustics settings, and turning on Reflective GI Caustics, and that managed to brighten up the scene, but the light still doesn’t go through the windows. I’m not sure what I’m doing wrong…

Any help would be appreciated!


#2

You should really post an image of your GI, Caustic, and Light settings. My guess is you are missing something that makes them work properly. For example, the GI Caustic settings enable caustics for indirect lighting only. To get Caustics from Direct light you need to enable caustics in the Render Params and on the light.

-Eric


#3

Not sure why I didn’t think of this before, but it seems stupid to me now that I didn’t do it in the original post :banghead:
Oh, and of course I enabled the Caustics themselves, not just the GI caustics… I’m a newb but I did read the manual :slight_smile:

Anyway, here are my settings:
[spoiler][/spoiler]


#4

Did you enable Caustics on the light? Can you post the file of just the walls and glass for someone to look at?

-Eric


#5

I’ve uploaded a very basic version so you could check it out. Just a VRay Sun, Sky, the room and windows, and the camera. Still having the exact same issue.

And yes, I’ve double-checked, and the lighting is set to generate caustics, and everything else is set to both generate and receive them.


#6

I don’t know why you thought you’d need caustics on this scene. You only need then if your looking for a very specific effect (like pools, underwater).


#7

I would need it for several close ups. You can actually see the effects of it already on things like the curtain railing (from the GI caustics, I’m guessing). Especially a close up of the sink, since that entire surface is glass. Problem is, if the light doesn’t travel through the window panes, no direct light will be there for the caustics to show up at all.


#8

The easiest way is to turn the caustics on only on the close up shots, and place some extra lights inside the bathroom to help the effect - even hide the glass panels on these shots.

The way you’re trying to do - one light solution to all the shots - is rarely (if ever) used. You’d normally want to tweak the light on a per shot basis to maximize the beauty of such image. Of course you can do the way you’re trying, but even professional photographers adjust their sets using reflectors and diffusers to “improve” the natural lighting.

Cheers.


#9

Thanks for your reply Davius.
I will try to set it up like you said, it does seem more… “cost-effective” when it comes to the total render times.

I would still like to know what’s causing the problem, though, for future reference :wink:


#10

Okay… so… I think I found the actual problem…

[spoiler][/spoiler]

So, can anyone help me figure out what the heck is causing this? It seems like the caustics are reacting to the sun as though it were a spotlight… if I move the glass, that “splotch” stays in the same place relative to the sun’s location.

Edit: D’oh! VRaySun params > photon emit radius. How the heck did I miss this one…
Thanks for your help guys. Increasing that value solved it.


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.