(Updated 25/7/2017) FFmpeg plugin for 3ds Max 2015-2018


#41

Hello everyone, I am trying to install this plugin in 3dsmax 2016 and I get this error.
“DLL <C:\Program Files\Autodesk\3ds Max 2016\stdplugs\ffmpeg.bmi> failed to initialize. Error code 126 - The specified module could not be found.”

i followed the instructions and copied all the necessary DLLs where they should go and installed FFMPEG.
Am I using a wrong path?
Thanks in advance!


#42

The plugin is in the wrong folder. From the first post here:

For 3ds Max 2015/2016:
copy ffmpeg.bmi into maxroot\stdplugs
copy ffmpeg.bmi.mui into maxroot\stdplugs\en-us
Not just maxroot.

-Eric

EDIT: Sorry I went by the text as the image wasn’t loading.
Did you miss type the text? Or are you still getting the error in stdplugs folder?


#43

Yes Eric, my bad, I miss typed the error text. I followed the instructions and copied ffmpeg.bmi into maxroot\stdplugs and ffmpeg.bmi.mui into maxroot\stdplugs\en-usI and still get that error window.


#44

Are you using the correct FFMPEG build? From the initial post:

This plugin(2015-2017)* requires FFmpeg 2.8.6 LGPL library, download from here:
Link1(Official):https://ffmpeg.zeranoe.com/builds/w…pl3.0-opencl.7z
Link2:http://7xt4sg.com2.z0.glb.clouddn.c…pl3.0-opencl.7z

Not sure if it works with the latest FFMPEG builds or not.

-Eric


#45

I downloaded the ffmpeg from the links provided in the instructions but I didn’t look for a specific version thinking the newer the better.
This is the version mentioned in the readme.txt in FFMPEG’s folder on C:
FFmpeg version: 20170130-cba4f0e


#46

You are probably missing opencl.dll in your windows\system32 folder. I had the same error and after some debugging I found out that dll had been gone missing. Reinstalling nVidia drivers will probably fix it.


#47

Thank you for the suggestion jonadb.
I will let you know if this works, once I try this out.
Cheers!


#48

post deleted


#49

Any news for a 2019 version?


#50

Yeah, 2019 would be nice!


#51

Would also love a 2019 version, is the code open source?


#52

Ren, those links to the lgpl version of FFmpeg 2.8.6 for Max2017 are broken. Please Help!