Unwrap UVW in 3dsMax 2013 - something wrong


#1

Hey guys. My first post here on cgtalk. I recently got back to playing around with 3Dsmax. After 8 years approximately. I have modeled a dagger that I want to texture. Ive never worked with Unwrap UVW before, now I have followed many tutorials. I add the modifier, edit the UV and choose Flatten Map or something. It lays it all out and i render the map. Color it in photoshop and save it, use it as texture, but it doesnt sit like I painted it. This is just a roughly explained description, but maybe someone has tried the same and knows how to fix it? Sorry, I really am a noob at this, especially texturing. I really hope someone can help me.


#2

Can you post a screenshot of the problem?


#3

Omg, why did my post only get in here just now? It was hours ago that I posted it. Anyway, sure. I just took some screenshots.

http://i50.tinypic.com/2s1asr6.jpg
This is how the UVW map render. I chose flatten, rendered the UW. Saved it. Made the metallic look in photoshop and used it inside the UVW editor AND gave the texture to my dagger. I know its an ugly texture but it’s to see how it fits so I can paint it accordingly.

http://i46.tinypic.com/2vjyj51.jpg
This is what comes out when I render. It looks like the old chrome texture I gave. But I used that UVW picture from photoshop that I ALSO used inside the editor. I dont get it. Its bugging me like crazy!


#4

Tough to say without seeing a screenshot as Dillster mentioned.

Make sure you didn’t delete the modifier off of the stack, and also be sure that your texture is being applied to the right map channel.


#5

Are my posts ever gonna appear here so that I can get the help I need??

EDIT: See this instantly came in. But I wrote another reply yesterday and it hasn’t shown up yet. I have no clue why. Do I need to try and repost it or is it because a moderator is waiting to acknowledge it before it shows up? I’m very confused.


#6

Im gonna try explaining one more time. I put on a Unwrap UVW in 3dsmax and select everything and do a flatten map, or w/e its called. Then I save the render of the UVW and “paint” a very ugly texture on it in Photoshop and use that new picture as texture in 3ds max.

This is how it looks in “Edit UVWs”, with the render as picked texture.

I give the texture to the dagger but it still renders like its old texture is on:


#7

You’ll need to assign a material using the newly painted map(in case you didn’t).

You unwrap can be improved a lot though, right now you are wasting a lot of space.

is it because a moderator is waiting to acknowledge it before it shows up? I’m very confused.
It’s actually explained in the FAQ
http://forums.cgsociety.org/showthread.php?f=79&t=886530

First two posts need to be validated.


#8

I did assign the newly painted material (the UVW) to the object. In the material library it still shows that the first material (chrome) is used in the scene. And it was on the dagger where I just put the newly painted material on :-s Why does it show that there are 2 materials on the same object? And why does it go wrong in 2 ways:

Either, the chrome material appears in the render even though both materials are used on the object.

OR. The newly painted UVW map appears on it, but doesnt fit as I chose it to, in the UVW Editor.

I’m so desperate for a solution. I need this to succeed or I’m afraid I’m gonna stop trying again :frowning: I just started and I want to have just a bit of success >_<


#9

Why does it show that there are 2 materials on the same object?
because there’s probably an Shell Material assigned to the object.
http://download.autodesk.com/us/3dsmax/2012help/index.html?url=files/GUID-424F8886-D39C-433D-A7DE-8ACDBAC0869-2031.htm,topicNumber=d28e395008

Like I said, create a new material, use the painted map, assign the material, render.
Or adjust the shell material.

OR. The newly painted UVW map appears on it, but doesnt fit as I chose it to, in the UVW Editor.
It doesn’t fit too well in the unwrap either, so what do you expect. Picture of that render would be helpful.


#10

I know it doesnt fit well. I suck at it. But the render (that I cant give you now cuz I’m in school) is much worse. Its like that UVW map is repeated 10 times (very small scale), and is rotated 90 degrees so it crosses the daggers from an angle. So its not that its on but displaced a little bit. Its very displaced and scaled totally wrong. I might just give up, if you dont know what it is. Cuz I have no way of figuring this out on my own. Thanks for the help so far, nonetheless :slight_smile:


#11

Explain step by step what you did to this point and we could try to figure out what went wrong. Or upload your file(as 3ds Max 2012 or below).

And object like your dagger ist pretty straight forward to unwrap. Is the object symmetric? If so, convert to poly, delete one half.
Then I’d do is assign material IDs to different elements. ID 1 for the topside,ID2 for the backside, ID3 for the blade and an ID for each of the holes.

Then unwrap each ID while hiding the others. Topside should be the easiest part, just flatten it.
back and blade can be flattend to, just not in one go. The holes are pretty easy, apply a box uvw(in the unwrap).
Apply a checker map to your model in order to have a visual control, to see distortions.


#12

Ill Try uploading the file or if possible, send it in a pm to you. Ill also try what you said.


#13

No one can help me? :frowning:


#14

upload the file


#15

Did you even tried my suggestions? Sorry for not being able to look into your file, it was a busy week for me.


#16

Yes, I did. I can’t do it. It’s too difficult for me, probably cuz I made a retarded model or something.

CompanionCube, here is the file: http://www.filedropper.com/dagger


#17

What part you are struggling with. Your model maybe retarded, but it’s a rather easy one, not overly complicated so I suggest you try again.

I wrote down the steps needed so if you have problems tell us which at what point instead of saying “i can’t”


#18

Same as before. I can’t unwrap it. When I do a test texture with UVW map render. It doesn’t show on the render. And it doesnt apply on the object like I hope it will. I can’t really go on from here. I’d appreciate it if you would take a look at the file and try to do it for me, so I can study what you did. Otherwise, I’m gonna playing around with 3D. Haven’t tried more since last failure :slight_smile: Understand if you don’t want to bother.


#19

well, in that file the model is not unwrapped at all. what happened to the file where you had unwrapped the model?


#20

I didn’t save it, appearently. I tried it many times but I failed every time. I’m just gonna give up, thanks for looking into it.