Unreal Engine 5 Alembic Motion Blur


Hello all,

is anyone familiar with the workflow Unreal Alembic and Maya?
I just can’t get motion blur on my fluid simulation.
That it must work somehow shows the following video:

I have already asked in the Unreal forum and also in the comment section of the video, but get no response.
The only difference I have is that I use Maya to create my ABC cache insted of Houdini.
Otherwise I have been able to adopt everything.
Here are my settings:
Maya Almebic Cache export:

  • Motion Vectors are baked into the geometry via Bifrost.
  • They look correct in the viewport. I don’t know if Unreal needs a specific name to recognize the vertex color as a motion vector so i tried the following names for the vertex color:
  • bifrost_velocity (The original name)
  • velocityPV
  • velocity

Alembic Export:
UV Write: On
Write Color Sets: On
Write Visibility: On
Write UV Sets: On
File Format: Ogawa

I also added an attribute in the Attribute section "motionVectorColorSet "

Unreal Engine 5:
Import Type: Geometry Cache
Motion Vectors: Import Abc Velocities as Motion Vectors
Project Settings> Rendering Settings> Default Settings> Motion Blur On
Material Property: Output Translucent Velocity

All other objects have Motion Blur. Even another Alembic object.
However, one with a non-changing topology. Here I have chosen the other import function.

If I should have forgotten something I would be very grateful if someone could give me a tip.
I just can’t think of anything else I could change before I switch to Houdini.

Thanks in advance