Unpremultiplied alpha in Photoshop?


Is there any nice way to save images with unpremultiplied alpha in PhotoShop?
The way I do it now is to open the image in Combustion and from there I save it with the alpha not premultiplied.


No way that I’m aware of. Photoshop does a horrible job of handling stuff like premultiplied alpha. In the attempt to make things “easier” photoshop hid all those sorts of controls away, which leads to difficulties when you need to move alphas from app to app. The workaround you have now may be your best bet for the moment.

  • Neil


Ok, that’s what I thought. But I hoped that it was a workaround inside PS…
That option (and a bunch of other stuff that’s missing) will hopefully show up in cs10 or something… :wink:


I wouldn’t hold your breath. Photoshop was never meant to be a professional “compositing” package, and the vast majority of their customers create and manipulate their images entirely within photoshop, never moving assets or results from other non-adobe packages. I believe the only reason they even added higher bit depth support (16bit, etc) was because the photography market was moving towards the raw format, probably had very little to do with the miniscule visual effects market. I’d be totally happy if they proved me wrong though, and added a few more controls.

  • Neil


Actually, under the layers menu in photoshop, at the bottom in the matting options, you have the ability to “remove black matte” (or white matte). This basically will un-premultiply your image for you so that you can use it in photoshop without getting that black outline around the edges of your renders…

Hope that helps.



Could you explain how that works exactly? If I have an image on a layer that’s premultiplied, and choose that option, it does not un-premultiply the image. Am I missing something?

  • Neil


I’m not sure exactly how it works…and perhaps I am wrong in thinking that it actually unpremultiplies the layer, but it has seemed to work for me the few times that I have used it (I do most of my compositing in Fusion, but use Photoshop for print size comps once in a while…).

Anyways, I just googled the topic and came up with this article…it seems to say that it was an option added in the CS versions, but up until then it was only possible to use straight alpha’d images in photoshop…Granted it only works for images premultiplied over black or white…Here is the link…




Hi Brian! If you look at the attached picture, the left part is the image with premult and the right unpremult. I would like to be able to save it like that inside photoshop, to get this result I had to re-save from Combustion.
The thing that you’re talking about is the opposite direction.


What Richard said. :slight_smile: But thanks for pointing out that feature, didn’t know it was there and it may be useful for something else sometime.

  • Neil


Alright, sorry that it wasn’t what you were looking to do. But it is useful when you are comping premultiplied images directly in photoshop. It will get rid of the black outline caused by the render being premultiplied over black originally…

Anyways, I think you have the right idea by just doing the conversion in Combustion, I think that will give you the most predictable results.

Let us know if you find any other solutions to the issue. Thanks.



I found one solution to this problem, GIMP :slight_smile: It can save tiff with un-pre.


Hey, maybe it’s to late, but it will help to someone who search for it. Solution is the ProEXR plug-in for Photoshop and After Effects, which can do Import/Export process more handled.


i’m a bit late either, but this may help:


I believe the RGB in Photoshop is always stored and used ‘straight’ internally - it’s just that Photoshop won’t show it to you without premultiplying it by the alpha. So it looks like it is premultiplied.

Here’s some stuff.

Compositing Premultiplied CG in Photoshop

I’d say maybe try the ‘divide’ blend mode in the Gimp, or unmult (free plugin) and render one frame in AE


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.