Turbosmooth distorting UV edges?


I am working on a model that I take frequently between 3dsm and Zbrush. Pictures at bottom.

My workflow is as follows:

  1. Create low poly base mesh in 3dsm.

  2. Using smoothing groups and turbosmoothing I subdivide the whole model without losing the overall shape by using smoothing groups.

  3. Take the turbosmoothed model into Zbrush where I can subdivide even further without losing the form/shape. If I would take the low poly mesh into Zbrush and subdivide it there I would get very bad results since I couldn’t keep the shape like I can with smoothing groups. Technically I could do it with extra geometry, but that is something I’m avoiding.

  4. Sculpt details in Zbrush and bake out normals and apply to the low poly in 3dsm.

This method has worked pretty well except for a minor issue. Basically, when I apply Turbosmooth, the seams of some of my UV islands get distorted. Those distorted UVS then get taken into Zbrush and baked onto. So when I apply the normal map to my low poly, the distortions are very obvious since the UVS of the low poly have not been distorted by Turbosmooth.

Here you can see the subdivided UV map on the left gets curved edges while the unsubdivided has straight edges.

Here you can see the distortion inside the red circles.

I did google the issue and found multiple threads about it, including ones from cgtalk like this however none of the solutions listed there work. Except the one about adding more geometry but that I’d prefer not to do, same with adding a UV unwrap modifier on TOP of the Turbosmooth because then I could not use my normal maps on my low poly model.

I did try splitting all edges, copying the Channel info, and pasting after disabling the edit poly where the splitting occured. No luck.

Most of the threads I found are at least 1-2 years old so I was wondering if there are some common workarounds for this issue?


edit: Ofcourse I “found” a way to fix the issue somewhat a few minutes after posting this thread. Detaching the affected polygons to element seems to minimize the problem. Although it has not completely disappeared.

However I’m not sure if that might cause other issues along the way, for example when I’ve taken it to Zbrush and start doing normal bakes since now many parts of the object are seperate geometry.

I’m still interested in hearing more solutions to this or if I’m doing something terribly wrong. Also some others might be having similar issues and this might be helpful.


Take the low poly mesh into zbrush and turn off the smooth modifier (smt button) before you subdivide. Or use the crease function which is like zbrush smoothing groups.



I don’t know how “dense” your 3D object is, but what I do is to add a turbosmooth with 1 iteration, then add a UV wrap above it, unwrap it correctly, and then add another turbosmooth (with the iterations you need). You won’t have problems with your uvs this way.

Sometimes the “meshsmooth” modifier works too, you have to check the “old mapping style” option, but this isn’t working everytime (most of time it isn’t :stuck_out_tongue: )


I think the OP’s end result is a low poly game-type mesh so will not be a turbosmoothed asset. At least that’s what I got from the description.


While you’re at it, take a break and vote here at user voice:


So we can fix this turbosmooth problem ONCE AND FOR ALL!


Neil Blevins has been banging that particular drum for a LONG time without success.

And if they won’t listen to him…:wink:


Think this plugin addresses some of the issues as well :

don’t let this put you off voting for it in the user voice as well though.


That’s true! Neil is a strong advocate of this (and LOTS more essential features) missing/bugged/incompatible feature of 3dsMax. At least it’s “under review”, although I don’t know for how long and if it will result in any real implementation.

If only AD managers said “hey, you know what? I had this incredible idea - let’s do the top 5 most voted features (plus the 9th feature 'cause it’s UVs related :wink: ) of the Max uservoice, fix some bugs in the freetime and call it a new version!” Instant rush to buy new Max from all over the world!

If only… :shrug:


Yes, I have tried TS Pro and it does bring Max up to date with the other 3D apps but why, oh why couldn’t Adesk have implemented it this time round? All the work has already been done by Marius. Just pop it into the bloody modifier list!!


Thanks for the replies guys! I appreciate them.

Hotknife, thank you for the plugin. I will test it out this evening, I’ll update my post with the results.

Thanks for the link as well Davius! Found some of your posts on the issue when I was googling for solutions, some of those posts and threads are 5 years old if not older.

Hopefully Autodesk will fix this soon, although I find it highly unlikely seeing how old some of those posts/threads were…


Thanks for the replies and yes, you’re right. The model is supposed to be a in-game model, so I can’t unwrap a tesselated model.

There are a few reasons for why I didn’t disable the “smt” button or simply use creasing. I’ll post pictures.

Here is the low poly model:

Here it is subdivided a few times with the “SMT” disabled, as you can see the nose causes issues:

Here I disabled SMT only on the first subdivision and enabled it for the 2nd and 3rd etc:

Here is the creased model, although I guess I could place some more creases by hand by hiding certain polygons/faces and creasing the border but that can be a bit time consuming:

Finally, here is the pre-turbosmoothed model, I used smoothing groups to define the smoothing:

Things “fit” more or less and aren’t clipping through one another or getting randomly smoothed in places where I dont want smoothing. It only took a matter of minutes to setup the smoothing groups so I found this to be the most efficient way for me.

After sculpting details such as bolts and panel seams, using the normal maps generated from Zbrush work perfectly on the lowpoly, aside from the uv distortions caused by the Turbosmoothing.

Maybe I’m doing something terribly wrong in my other methods though?

My topology could probably be fixed in many ways as well.



(With all respect) This mesh is not modeled “to be smoothed” imho :surprised
Don’t get it why you want to smooth it with turbosmooth modifier ? Can’t you just use the smoothing groups on that chopper ?


Thanks for the comment, you may very well be right. The most important thing to me was to keep it rather low poly for ingame use. I’m well aware that it is far from perfect but I’d appreciate some tips on how I could make it more “smoothing friendly”. I should probably try to reduce some of the poles and triangles for better results.

However that is only a secondary issue, I think, since everything I need works almost perfectly.

After throwing up some bolts on the hull, I can extract a normal map which fits perfectly onto my low poly except the places where Turbosmooth has distorted the edge, the bolts seem stretched on those places.

I am using smoothing groups on the chopper inside 3dsm but they alone don’t do much when I take the model over to Zbrush since Zbrush does not read them at all. It completely ignores the smoothing groups I had set up.

The reason for why I’m using Turbosmooth is I want Zbrush to distort the model as little as possible when I subdivide it there. If I’d just subdivide it without the Turbosmooth, I’d get similar results to the ones I pasted above.

For me, it is quicker to set up the smoothing groups than using “crease” inside Zbrush.

I saw this Turbosmooth method in a tutorial few months ago, I can’t find it again now since I don’t quite exactly remember which site/forum I saw it on.

I will be testing Turbosmooth pro soon, I hope that solves the distortions at least, ignoring my other mesh related issues.

I apologize if I’m not getting my points across efficiently, English is not my primary language.


Can I say that there is another way to this pipeline that is worth considering :slight_smile:

Start with the High Poly in Zbrush - add the detail/colour and as much as you want - getting the look right in ZB.

You don’t have to worry about topology/Uv’s or pretty much anything apart from making a good looking model.

Then export the ZBrush model into Max, Decimate it first if you need to in Zbrush.
Retop this model in Max to create a Low Poly - this is the only object you need to unwrap which makes life extremely simple.
Then use Xnormal to project to Colour/Normal/Displacement/Curvature etc… of the original ZB High Poly model.

It’s a very fluid workflow as you can alter the high poly or low poly and just re-project in Xnormal.


I’m a bit confused about this. You don’t need UVs on the high res model if you’re planning to bake normal maps to a low poly model, so distortion in UVs when subdividing shouldn’t matter.

The high and low res models don’t need to match in any specific way, just occupy basically the same space.

I must be missing part of what you’re trying to achieve here.


I think the problem was that the unnecessary Turbosmooth upon import to ZB was causing the UV smoothing issues.

I have to agree with hotknife here though: The OP’s workflow is a bit messed up. It would be better to create the high-res mesh in Max. Send to ZB for detailing and lastly build the low-res game topology/create UVs. And definitely bake the normals in Xnormal as ZB’s normal maps aren’t the best.



Decimate it first if you need to in Zbrush. Retop this model in Max to create a Low Poly - this is the only object you need to unwrap which makes life extremely simple.

Thanks for the tip. I’m thinking about just doing exactly what you said. Just to be sure though I have a few questions about this if it’s okay. Wouldn’t it be a lot of trouble to retopo a decimated object or would I just create a “shell” around the decimated object from scratch? Wouldn’t I need to create a “cage” for the projection as well? For example with the Projection modifier in Max.


I’m a bit confused about this. You don’t need UVs on the high res model if you’re planning to bake normal maps to a low poly model

I apologize if I didn’t explain well enough or in a confusing way. My original plan was to do everything regarding the baking inside Zbrush and for that (to my knowledge) the subdivided version does require UVs since it is the same object as the low poly model. I do realize that UVs would not be required if I used some other program to do the baking, but that was not my plan at first.

One of the reasons I wanted to do this solely inside Zbrush is because I’ve used only 3dsm and Zbrush in the past for my organic models. Ofcourse, I don’t use turbosmooth for organic models nor smoothing groups.

This helicopter is one of my first serious hard surface modeling practices and I’m still just trying to figure things out. I was trying to apply my organic workflow to it but I guess it’s not the right way.


And definitely bake the normals in Xnormal as ZB’s normal maps aren’t the best.
I’m very curious about this. In what ways are ZB’s normal maps worse? Is that also the case in the latest version 4r5?

Thanks guys, I’ll be redoing this with a seperate high poly model for Xnormal since that seems to be the better way.


People mentioned Neil Blevin, but nobody posted one of his links so maybe this might help:


Particularly the part about using a UVW Unwrap modifier to break the UV’s before turbosmoothing and exporting. No idea if it will help or not, but it’s worth a shot. Turbosmooth Pro might be worth playing with as well, though I found it sometimes doesn’t work very well with smoothing groups.

I like to use smoothing groups to control the turbosmooth modifier too by the way. I find it to be a useful means of controlling how things get subdivided, particularly when you want to create creases without having to add a ton of extra edges.


Hi again,
The decimated version is just so it’s easier to create the low poly version in Max, I decimate from ZBrush into Max because the retopping tools are good in Max. I then either unwrap the low poly in Max or back into ZB. Yes essentially you create a new shell around the decimated version.
You dont need to create a cage to project, there is an option in Xnormal to use a cage I believe but I haven’t used it yet.

I’ve then got an unwrapped low poly the same dimensions and shape as the ZB high poly version. I then write the high poly, undec’ version to disk and reference that in xnormal.

Is a nice method as you can tweak both the high and low polys version independently and just resale and reproject…
http://www.zbrushcentral.com/showthread.php?175695-2013-Sketchbook …last image in post is similar panel work to your helicopter…


For whatever reason, Zbrush generates very soft, blurry normal maps. They look great in Photoshop but the rendered result isn’t as good. There are workaround through PS editing but it’s not worth the hassle when you can just do it in Xnormal.

Here’s a link to a good ZB to Xnormal workflow: LINK


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.