Transparent plastic material Mental Ray


#1

Hi All, I am trying to create a transparent material similar to that of a PET Plastic (water bottle plastic). I am having troubles with existing materials i have used as there are black sections appearing on the model where the material overlaps. Can anyone help out? Cheers


#2

Black areas on a raytraced refractive material could mean that you simply need to increase your raytrace depth settings.


#3

Hi Jeff,
Firstly thankyou, That certainly did alter the overall look of the bottle however there is still a large black area on the bottle where surfaces are overlapping. I tweaked the raytrace acceleration level from 40 up to 200 and and max depth is set at 80. Are there any other suggestions? I really appreciate your help. I am quite new to Mental ray. Cheers Tim


#4

Hi Jeff,
Attached is an image showing the problem area. Again thanks. Tim


#5

Right, so did you increase the raytrace depth settings?

It’s either that, or coplaner faces on the mesh.


#6

It doesn’t look like a trace depth problem, maybe a shadow problem.

Can you describe how this material and scene is set up?


#7

In the scene i am just using one Skylight multiplier 1.
The Material Is a Raytrace Phong, 2 sided diffuse and transparency both white. I.O.R set at 1.4 Specular level 125, Glossiness 60, Soften 0.1.

MAPS
Diffuse map: 100 (falloff) Blue and white with Fresnel falloff type.
Reflect map: 100 (falloff) Black and white with Fresnel falloff type.
Environment map: Kitchen HDRI

Thanks for your help, much appreciated.


#8

Hi Jeff,
Yeah i did increase the raytrace depth increased from 30 up to 330. Bottle looked better however didn’t really help where material is overlapping. Any other suggestions. Thanks Tim


#9

I’m not sure we’re talking about the same settings here. When I say raytrace depth I’m referring to the “trace depth” settings located in the Rendering Algorithms renderer rollout. The default settings are Max. Depth, Max Reflections, and Max Refractions all set to 6. You can try increasing all those to 10. I doubt you’ll need anything beyond that for this scene (and 10 is probably pushing the limits). If you increase it beyond that, and it’s not needed, then you’re just wasting CPU cycles.

When I mention coplaner faces, that’s referring to two objects located in the same space. Sometimes that’s a problem, sometimes it’s not. Generally, it should be avoided

Anywho, that’s just my thoughts. These may not be the actual cause of the problem. These are just the first things I’d check if I had this issue pop up in a render.

EDIT: In thinking about it, 3DMadness is correct…I also doubt it’s the trace depth settings at all. Because that normally happens at the back side of the mesh in question (item farthest away from the camera).


#10

Jeff,
You shouldn’t have doubted yourself, you picked it straight away. I was increasing the max depth, however wasn’t altering the max Reflections and Max Refractions when i increased those it fixed the problem. You’re a champ, cheers for the help. Tim


#11

Nice post here ! Thx to JeffPatton. But on more question : whats the difference bettween the “trace depth” settings located in the Rendering Algorithms renderer rollout, and the one in MR “indirect illumination” tab, with Final Gather options ?

When i change parameters in there, it will not affect my render … thx


#12

Basically:
Trace depth in rendering algorithms = raytrace depth
Trace depth in final gather = FG depth (similar to raytrace depth but controlling only the FG rays)


#13

What he said ^^^^

This is the raytracing settings for the shaders (materials) in the scene. Such as glass, mirrors and things like that.

This is the raytracing for the light bouncing around the scene. Such as sun bouncing around a room after coming in a window.


#14

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.