To every plugin user & developer (R15 changes)


#1

All source protected Python plugins created with R14 or earlier will not load in Cinema 4D R15. The developers of non-open Python plugins will have to re-protect their plugins using Cinema 4D R15. This can of course be done with the demo version of Cinema 4D, therefore this change will not force you to upgrade.

This does not apply to non-protected Python plugins (with the suffix .pyp).

Plugins protected for R14 or earlier can live in harmony with plugins protected for R15. The suffix has changed from .pype to .pypv so each Cinema 4D release knows which protected version of the plugin to load.

More details on my blog: http://niklasrosenstein.de/2013/08/cinema-4d-r15-important-python-info/


#2

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.