Textures missing in all imports. No broken links because... no links?


#1

Noob alert!

I’m in R20, and I’m basically not seeing ANY textures come through correctly for either fxb or obj imports.

After wading through a dozen or so threads and watching 3 tuts on similar issues, none of them match what I’m seeing.

Materials are importing with the models, but they’re all various shades of gray. I was under the impression quickest way to fix textures not importing properly was to go to attributes maager for the material, find one of the missing textures, tell it where to relink, and allow it to then automatically try to relink all others to same folder.

One problem… NONE of the links are there. I don’t mean they’re broken, I mean there’s no link. When I open the material editor, not one of the textures within is attempting to link to any file. I know this is not correct and have verified with 3 models now that I know have linked tex files.

I figure at this point, it must be something about my import settings that’s just erasing any reference to the linked files, but after trying quite a few variations, it’s still not working.

Likely troubleshooting step?

Some other way of importing? (I’ve been doing either File -> Merge from main menu or File-> Merge objects from the smaller menu on the right)


#2

Try to place your 3d-model in its textures folder, should work when cinema 4d loads textures from root folder.


#3

Where are these models coming from? Are you sure they were exported with materials and textures?


#4

Models from 3 different sources. Total of 2 fbx and 2 obj. They all have either tex folder with various files or .mtl file. Tried both with model inside tex folder, and in folder that also contains tex. Still going through each materials shows no linked textures. Just lots of gray.

Will attempt all other permutations of import settings I can think of this morning. As far as I can tell, I’ve followed the exact instructions on multiple tutorials now. Any possibility there’s some global setting that could be causing this?


#5

OK, I’ve tried this with 5 more models now from 3 different sites. I even tried to track down the exact models they were using in the tuts.

Whether I merge via file dropdown in main menu, merge object in menu on right, or just drag in the file… and whether it is an obj with .mtl in same folder, or fbx inside tex folder with option enabled to import textures either way…

… Every single time, I just get white or gray materials with no reference anywhere in the material to any of the files that should be linked (nothing is selected in the texture field for any of the channels).

I understand the concept, and see info out there about fixing broken links… but I’ve never seen a situation in any software before where the links themselves just disappear. To be clear: Materials are importing, but they’re all just blank. All references to the included texture files are voided as the texture fields are all just blank within the material editors. There’s nothing to relink because there is no broken link. The links are just not there.

This is driving me nuts for over 2 days now. Anyone got anything else to troubleshoot?


#6

Finally found one model that does import correctly, and trying to figure out what’s different about it.

At least a few of the others have jpg texture files, whereas the one that worked has png. Does c4d somehow not recognize jpg correctly for tex files, so it just ignores the links?


#7

c4d works fine w/jpg textures. Something else is going on there.


#8

Looks like a whole group of them I tried were from same artist. Don’t know if they got incorrectly converted from another format or what, but the tex files exist with no link to them.

I’ve gotten a few others working now, so maybe I just need to be wary moving forward about triple checking that there are not only image files, but check to see there’s a proper UV file in there somewhere, etc. and just be aware that folks on sketchfab may not have taken great care that their models work properly in all available formats.

A few were also tagged PBR. Those specifically had jpg image files in a tex folder, but nothing that looks like a uv map. On PRB models, do they typically just use photographs of the actual object as the UV’s? Is there some other accommodation that needs to be made to properly import them?

I did actually pay for one, though… so will need to dig into that as I still need the asset.


#9

My guess: These are models originally created in some other software and saved in a way that doesn’t preserve the texture links. I’ve seen this on many models purchased from Turbosquid…


#10

Yeah, that’s pretty much the conclusion I’ve come to at this point. Makes no sense to have tex files, and no links. I can create an object, texture it in c4d, output to those formats and back in, an it’s fine, so it must be their output process. Bummer. Something like 12 of the 16 or so I tried either didn’t have the tex files they claimed, or did, but had no links when the obj or fbx was imported.


#11

I think I still have a script that will restore textures to obj files but you need to have the mtl files as well. Let me know if you think that would help.


#12

I do have a few in that category.

.mtl fie is present, but nothing is linked on import.


#13

OK here is the link to the parse mtl file. The instructions are below.


#14

Let me ask you this: has this ever worked for you?

What you describe has been the behaviour for me for the last 8-10 years. I’ve never had an .obj or .fbx show up with anything other than a white material with no internal links.

Well, maybe it has worked occasionally, but it’s rare…

I’ll be following this to see if there is a good way to fix this,


#15

Yes, I just tried dozens of models, and eventually, some of them worked. Seems that either some creators are very sloppy in the way they translate from their native format or C4d is extraordinarily picky about what it needs to see on import.

Not such a big deal on some of the tests, but I paid good money for a few of them now, and some are WAY too complex to just retexture (why i didn’t build them from scratch in the first place.)


#16

If the UV layout is good and preserved, it’s probably not necessary to retexture anything, you just have to recreate a material and import the texture manually.


#17

In cases wehere it’s simple and straight forward as to what goes where, but for at least a few of these, I’m looking at a dozen or more textures that went in some unknown channel of some unknown material on a long list. The UV’s themselves are usually obvious at least which material they belong to, so if it’s mainly just a UV or two, it’s workable.

Generally speaking, though, if I’m importing something it’s because it was too complex or time consuming for me to create… which means in many cases, LOTS of materials to deal with.


#18

same here with an archicad exportet c4d file. comes from a client which models worked for years without problems. have no idea an no time to explore…


#19

What I have found to usually be the problem is the creator used a render plugin like Vray inside 3dsmax. When they export the files the non native materials are not exported correctly. The same thing will happen in Cinema when a render plugin is used.

-Shane