texture rate in maya 2013 not working


#1

I am unsure if this is a bug but now I cant use a custom texture sequence in a file node to emit particles.

It will only work if I stop playback and start again or go frame by frame.
Has anyone had this problem?
I use this all the time, first time it has happened to me.

I have seen other threads talking about this

http://forums.cgsociety.org/showthread.php?f=86&t=899966&highlight=texture+rate

but they are only prove it works with maya procedural textures, which work fine.


#2

There have been some developments on this subject since then.
http://forums.cgsociety.org/showthread.php?f=86&t=1061982
While the focus of this is nCloth stuff…the suggestions are valid solutions.
You can start by just making sure the texture is visible and updating in the viewport.
Using the suggested methods. Or go for the nuclear option and try customizing the included expression for your file node.


#3

thanks animatedfox, it ended up being the hardwareTexture resolution on the shader as long as its not on default it worked, did not have to go to as far as changing the expression in the node. I do have to say that this way it does become slower to sim

thanks


#4

Hi fxjungle I have had the same problem could you please give me a little more information as in how to change the hardware texture resolution this has been sending me mad trying to get a simple procedure to work properly.

Cheers


#5

Hi, I cant really remember my specific situation, it was last year, but I remember that it had to to with the display option on the Lambert material I was using

if you go to Hardware Texturing and play with text channel, res and filter you might be able to work

if that dosent help let me know your particular situation, maybe a sample scene and I will help you out.

Also, I think I was on 2012 at that time on a different machine, now I am on 2013 and I can’t recreate the same issue


#6

oh i see Im on 2013 I just attached the file sequence directly into the texture rate of the particles. ill try attaching a lambert instead. would i be generating via colour or alpha?? Thanks for your reply

:thumbsup:


#7

The file out color or alpha (depends on what you wanna use) should go directly into texture rate, but for some reason when its a file node (as opposed to a maya procedural), you also need to put it into the shader and change the texture res to low


#8

I have the same issue on 2013. I have to assign the texture to the particle emitter texture emission slot and to a lambert or surface shader which I assign to the emitting geo and turn on texture display in viewport which makes the viewport update very slow because I’m using a big texture map for emission.

This is a very annoying bug but hey we are used to do workarounds, right :wink:


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.