"Texture Paint" mode stopped working


#1

Today the “texture paint” mode stopped working. I can still paint on the image in the “UV/Image Editor”. But when i try painting in the “texture paint” view the circle cursor stays where i initially click rather than following the brush icon.

I have tried toggling all the options i know of, and creating new textures. (1024x1024 and 2048x2048). If i start a new document, i don’t have the problem just painting on the default cube… i’m using 2.49.a on vista.

Possibly related: Yesterday painting in “texture paint” mode applied paint to the wrong image unless i painted directly in the “UV/Image Editor”.

Any help, greatly appreciated!


#2

I’ve had this issue before, it may be a bug, although i too had thought i’d clicked something.

I’ve found the only way to get around this is to save your image and the .blend file and restart blender, then it should work upon restarting.


#3

Looks like i’m not that lucky :sad:
I tried saving map and blend as a different name, restarting, rebooting. I imported the scene into a new file with no change as well.

Thanks for the response though. Still good info.


#4

hmm any recent graphics card driver changes?

Have you tried upgrading your driver or turning down hardware accelleration?

Is full screen antialiasing off?

LetterRip


#5

Thanks!!..I didn’t change any of that between the time it was working, and stopped working. I did change vid cards and driver a week or so ago though… I don’t see a setting for full-screen anti-aliasing in my nvidia settings. Will look into that more though.

Here is an update…
I managed to get past the problem by appending the object from an older file into a new scene. That somehow worked.

But a problem that remains is when i paint on the object in the 3d view it paints on another texture that isn’t even being used… regardless of what map i have selected in the uv editor :banghead: Is there a way to specify what map i want to be painted on?

Any tips on this latest issue would also be greatly appreciated as well :slight_smile:


#6

hi!
you can only paint on the image that is assigned to the uv-layout in edit-mode, regardless of which image you actually see in the editor, if you are in object-mode. well, of course you can do image-paiting directly on the image in the image-editor, but i assume you are talking about 3d-texture-painting.

if you want to change the image that you want to paint on, go to edit-mode (not object- or texture-paint-mode) and assign a new image to the uv-layout there. you can also use multiple uv-layers or uv-textures. have a look in the mesh-panel in edit-buttons. make sure the right uv-texure is active (just in case you have more than one).
sometimes you have to make one of the faces in the uv-layout “active”, just by selecting them with RMB, before you are able to change the assigned image.

about that cursor-problem you mentioned: could it be that you have painting-mask enabled? maybe by accidentally hitting “f”? if that is the case then you can only paint on the selected faces. quite handy sometimes, but it can be confusing if enabled by accident without knowing. just try toggling it by hitting “f”.

hope that helped, because blender’s texture-paint-tools are really powerful and are doing a good job, so it would be a pitty if they wouldn’t work for you.
cheers!
sebastian


#7

I found this video tutorial helpful in projection painting.

http://www.cgcookie.com/articles/2009/06/18/projection-painting

I might have had similar problem also when painting, I would delete UV layer using X button next to it and make new one to paint object at other angles. It got to the point were it would not work also. I thought it might be the creating of new UV layers to many times caused an issue so I would instead re use same layer to project paint from. Have not had a problem after that and reused layer about 20 times for painting.


#8

Hi Sebastian-- You just solved both problems. I was trying every combination of settings i could imagine, but wasn’t trying them while in edit mode :stuck_out_tongue: …I am still pretty new to Blender, but have learned a ton about modeling from your videos. So much so that i purchased your cmi video. Excellent job on that! I would love to see you do a tutorial video on painting some time… Thanks a BUNCH for your help!!!

Nifty-- Sounds like a great tip. Will keep that in mind :slight_smile:


#9

hey fuzatron!
i’m glad i could help, and also that you liked my tutorials. :slight_smile:
you know what? i may have something in the pipeline that could interest you :wink:
i’ll post here when it’s ready.

about uv-texture layers:
you can use up to 8 different uv-textures (or layers. the term uv-texture is somehow confusing IMHO). and not only can you use them for projection-painting, but for different textures too. just fill in the name of the uv-texture-layer in to the text-field “UV” in the “map input” panel in the texture settings. that way you can have multiple mappings for different textures in 1 material.
if you click on “new” to add a new uv-texture in the edit-buttons while you are in object mode, then that uv-texture gets duplicated. if you add “new” in edit-mode, you’ll get the default UVs and have to unwrap again.
but before i write too much here - well, eventually there might be a whole new tutorial about that topic. :slight_smile:

cheers and happy blending!

sebastian


#10

That’s some more really good info. Thanks for that!
I will definitely be on the lookout for whatever it is you might have cooking :wink:


#11

Hi my Blenderpartners , i wanna know if i can paint with the uv’s and the model at the same time like Bodypaint see this picture

I reallly like your answers


#12

If i understand correctly, you can already do that.

In the viewport switch to texture painting mode, in the UV editor turn on image painting, you can then go back and forward between the two windows, it’ll update in each window, however you have to adjust the brush sizes between the windows, as they differ quite alot.


#13
Hi DanielWray  , know that Blender can paint both sides but i have a question i can't resolve
  • when I paint i have this imagen in texture paint but without Uv’s
[img]http://i278.photobucket.com/albums/kk106/carlos_tetris/2-4.jpg[/img]
  • but when i wanna see my Uv’s but i have to change to edit mode and my paint in my model change :frowning:

  • but my question is ¿how can i do to work with my Uv’s and model without changing to edit mode to texture painting like Bodypaint? .

if there is an opcion please show me :). Many thanks


#14

I’m hoping there is a way to do that too, Alekzsander. I haven’t found a way yet either, but will post back if i do.


#15

Turn on wireframe drawing (option to have wireframe show up on top of shaded mode) i think it’s in the F6 panel.


#16

that shows the wire in the 3d-view, but not the uv-layout (at least not for me).
would be really nice to have, i didn’t find it neither.


#17

Same results here. Ah well =/
Really surprising that the uv’s can’t be displayed like that.


#18

im gonna prove it , thanks


#19

yeah, for some reason, there is an option for this but it only shows in edit mode. :frowning:


#20

Ah right i understand now, i never actaully noticed that issue before.

Hopefully it’ll be changed so you can paint in the UV and 3D window with out having to go into edit mode or changing any settings (brush size!).