Team Render Problem With Client Renders


I just set up a Team Render configuration with the latest release of R19 Studio, including two iMacs and a Mac Pro. Everything set up well and appeared to be working when I began the render. Then, I noticed that the two clients were showing errors in their client windows. Plus, the renders from the two clients were not complete. What was occurring in the clients was that 1) the Book Generator was not generating books in the client renders although in the Master computer renders the Book Generator was generating books. Plus, 2) wall and floor textures were not being displayed in the building generated by House Builder although the textures were being displayed in the Master computer renders. All computers have R19.053 release installed.

Any suggestions what might be causing this and what to do?



Do the client machines have those two plugins installed within the Team Render Client’s plugin directory?


The plug ins are the same for the Master computer and the clients. It’s not clear to me what or if any plug ins are necessary for the NitroMan Book Generator and House Builder. I checked in the Master plug ins folder and could not locate any plug ins labeled for NitroMan. It’s not clear to me how NitroMan operates within C4D - whether it is a plug in or not. And if it is, how is it labeled in C4D?

Any other suggestions?



IS there a reason the generators need to be active rather than just making them editable? I would bake them out if you can do so with the rig , expression or plugin (whichever it is) isnt neccasary.


“I would bake them out if you can do so with the rig , expression or plugin (whichever it is) isnt neccasary.”

It’s not clear to me how I would go about “baking” them out. They are products of generators. So, how do you go about “baking” out the products of generators?

Please advise.



Are the generators animating in any way?

If not–then just click the make editable button on the generator and you have the geometry.

If its animated–you can export as an alembic file. Not sure exactly what your situation is. maybe post a clip? or the file.


Are you using magic book?

or nitro book case?

If so then it is indeed a plugin and needs to be saved in your client plugin folders.

Seems to be the same with nitro floor which is part of the nitro room plugin set


I’m wondering if either of these are now included with C4D by default in one of those asset libraries that I don’t use but probably should. That could be where he’s accessing them from.


I was wondering that too.

in THAT case…

Maybe he just needs to do a save projects with assets?


Save Projects With Assets - I did a save projects with assets. That did not seem to help with the problem.

Magic Book - No, I am not using Majic Book. I simply accessed these generators from the Content Browser. They both work fine if I do all the rendering in my Master computer. My plugins displayed in Plugins on the Master just show COFFEE & Python.

Here is one of the error messages from one of the Client computers of which there are several like this:

File “HouseBuilder - NitroMan”, line 22, in main
TypeError: argument 1 must be c4d.BaseList2D, not None

Any suggestions what that means or what to do about it? Thanks!


That’s a generic Python error message, and there’s not much we can do on our end to solve whatever it’s referring to. Maxon would have to investigate it.

Have you tried exporting the House geometry that’s generated by the House Generator as an Alembic cache, and using the alembic geometry in your scene instead?


I just tried making the Generators editable. So far, so good. It appears that may have done the trick.

Thanks for the help!