subScatter for MR shader pack Updated


#1

The updat was the 11/11/2003 for updated date.
Hope it will enable multi light… :smiley:
Vinc


#2

It works with multiple lights.

Has someone figured out a way of using this shader with a texture. Like marble stone. I´ve tried connecting it to absorbtion but it gets negative so i´ve used a reverse node but it doesnt look good.


#3

This version is so much better! I can actually get it to work now and the presets are a great help!

Unfortunately when I added a second light it crashed for me…

:shrug:


#4

Just tried rendering with six lights. Works for me.


#5

Ooohhh well sorr-y Mr I-can-use-multiple-lights-and-you-can’t!

Hehe, I’m just joking. It’s probably because I’m batch rendering in the background so everything’s going mega slow.

:stuck_out_tongue:


#6

Sorry! Didnt mean it like that. Thought maybe there was a bug or something.


#7

Hey Pix, did you manage to force SSS to be transparent. I just cant see trough the shader. If you did can you pls post your shader settings…thx :wink:


#8

so where can I get this shader then?


#9

Shader is here : http://www.lightengine3d.com/index2.html


#10

Hej Peter!

Theres also a great sss MR shader here: http://www.andymator.co.uk/shaders/tranvol2/index.html

Ozren,

Im not quite shure what youre after but I tried connecting MDs sss shader to a Surface shaders outColor AND outTransparency.
Seems to work.


#11

HEY! have you really try it?
Like for the previous version… as soon as i add a second light, i have million off error like that :

PHEN 0.3 error: ERR0
PHEN 0.3 error: ERR1
PHEN 0.3 error: ERR2
PHEN 0.3 error: ERR3
RC 0.3 error 081003: shader “mr_subScatter” called mi_sample_light with unknown light tag 0

It appears in the output window( NOT SCRIPT EDITOR )… have a look at it and give reply please.
Over thing, the absorption and scattering attribute seems to have been modified. I have add to reverse one before not now. Why not. But i have strange result by connecting a texture file to the absoption attr. After search, it apperat that it was the Blue channel of the color that produce this result.
Ok People… give real try please, is there any body who can use multi light for the scatter (selected in the scatter light feld… ) ??
Vinc


#12

Multiple lights work for me. I use the latest version of the shader from lightengines site.


#13

…multiple lights work for me, too. (i also use the latest version)


#14

I also have this error when opening the ss_mr_teapot.ma file that come with the shader pack. May be it’s for the same reason than my multi scatter light don’t work. :shrug:

// Error: file: C:/Documents and Settings/blabla/Bureau/scenes/ss_mr_teapot.ma line 41632: The mr_subScatter ‘mr_subScatter1’ has no ‘S17’ attribute. //
// Error: file: C:/Documents and Settings/blabla/Bureau/scenes/ss_mr_teapot.ma line 41632: The source attribute ‘mr_subScatter1.S17’ cannot be found. //
// Error: file: C:/Documents and Settings/blabla/Bureau/scenes/ss_mr_teapot.ma line 41641: The mr_subScatter ‘mr_subScatter1’ has no ‘S16[0]’ attribute. //
// Error: file: C:/Documents and Settings/blabla/Bureau/scenes/ss_mr_teapot.ma line 41641: The destination attribute ‘mr_subScatter1.S16[0]’ cannot be found. //

Strangely it also happen with the scene I made including the previous version of the ss node.:annoyed:
Am I the only one with this?
Vinc


#15

Are you running xp?
In another thread about the dirtmap mental ray shader Buki says: “A .dll file was missing from windowsXP system32 directory, it’s called msvcr70.dll
Just type this in google and download it.”

Don´t know if it has anything to do with your problem but maybe worth a try.


#16

Nice try!
I effectivelly use XP ( no choice for that here :annoyed: )
But this file exist for me and the ones on google are older.
My dirtmap shader working fine also.
It might no be that. :shrug:
Anyway, Thanks Pixero.
So, over suggestion?
Vinc


#17

I get those same errors as Vinc when I open the teapot scene, and still can’t use multiple lights either.

Have you got the 5.01 upgrade installed Pixero?


#18

I have Maya 5.01 on XP.
I also got the error messages when opening the teapot scene.
Maybe somethings wrong with that scene?

When I create a new scene it works and I can use multiple lights.
I connected the shader to the outcolor of a surface shader and set it to mode 2 under extra attributes.


#19

Yes, it’s works with multiple lights, but too slow. It seems rendering a pass for each light and then composite them is much more faster way.

Also, using bumpmaps with base material causing some artifacts, someting like when you use high frequency displacement maps with polygons with maya renderer.

Altough there are still some troubles, this version gives better results, and gives them faster. Thank you Mark Davies :thumbsup:


#20

Ohh mode 2? I didn’t change my mode hehe.