Struggling With SubTools


#1

I’m a university student currently learning ZBrush and we’ve just learnt about SubTools, however, when I am creating a shirt for my character using the Extract tool is it creating a second mesh inside my first one and I don’t know how to fix this or make it not do this in the first place

. Does anyone have any advice?


#2

it may be because of your mask. If the geo your are masking to get an extraction has a thickness, you may be masking the inner layer also.
If that’s not the case, it may be you double turned on under extract.


#3

I think it’s because the geometry I’m masking has a thickness, is there any way around this?


#4

Yep. Just go to Brush - Auto Masking - Backface Mask


#5

It’s still doing it when I hide half of the mesh, I tried extracting with 0 thickness but then I can’t use the move tool on the mesh :\


#6

so what you’re trying to achieve is a solid mesh without thickness?
When you extract it, it should give you a polygroup of the thickness. you can try getting rid of that. autogroup after so you have different polygroup from the inside shell and outershell. Get rid of the innershell also. Then you can close holes, so you have one solid mesh in the end without any thickness.


#7

Extract is for adding thickness
if you dont want thickness but want another copy then press tool>subtool>duplicate.
when you duplicate it will make a copy in the same postion and make it appear as 1 object
so you will need to offset them to see 2 copys

if you ctrl+shift drag and you see the green rectangle box to hide part of the mesh
then your mesh may not be showing the thickness because your hiding it by ctrl+shift drag

to see the thickness ctrl+shift CLICK.
click off the mesh not on the mesh


#8

Also remember to untick Double before you it Extract, otherwise it give an extract on the inside of your mesh as well as the outside.