strange texture errors/glitches in 3dsmax 5.... HELP


#1

Last weeks i have been very, very busy making pieces for my portfolio. But now i have encountered a problem and i really dont know what i have to do.

When i made a test render i saw the first glitches. some object lost there textures and instead got a plain grey or white color. I rebooted the computer but that didnt help

Well maybe the links to some textures were broken, i thought. That wasnt the case and when i wanted to reload the texture i got an error message:

  After the second test render things got worse. Some objects became completely white.
  [img]http://img35.exs.cx/img35/8918/TEXTURE_GLITCH4.jpg[/img]
  
  And this is the third test render which i find even stranger with dark lines over some objects.
  [img]http://img35.exs.cx/img35/1280/TEXTURE_GLITCH04.jpg[/img]

A screen of the material editor. You can see that some textures became “bright” white although it still links to the texture. When i do “view image” i get to see the texture, but when i reload it i get the same I/O error as before.

And here is a pretty old render when i was about 70 percent into the texturing process and not all the enviroment props were in place.

I have tried different things like changing the image format, loading the textures from another Hard Disk, but everytime i get the same Image I/O error.

I hope i gave enough information and that somebody can help me because i want to finish this and my portfolio as soon as possible as i’m in need of finding work.

 Thanks in advance,
Reinier.
  
  Hardware: 
  Pentium 4 3.2 Gig
  2048 mb memory

#2

Sounds like a memory issue to me. Is max paging to disk? Reduce wireframe detail and maybe also the texture sizes, see if it goes away. For example, delete half the model, close and restart max, load half-deleted model, render… does it work?


#3

Eric Chadwick… i did as you have said and this is the result after deleting some objects

indeed, many textures begin to appear again!

End after deleting some more… So now i’m gradually making textures smaller and hopefully it will be fixed. Thank you very much for your help! :smiley:


#4

I had this same problem once, I have kinda the same fix as Eric but slightly different.

Open a brand new file after rebooting. Click the import button and choose your existing file that’s giving you trouble. Import 5-6 items at a time then render it. If it renders ok then save and import some more items in. Keep going until you have everything in. For some reason I was able to get all the objects imported into a new scene, and the problem went away.

Hope that helps, that was my fix and only happened to me once. crosses fingers

-Deathcricket-

:edit: FYI I did not have to resize any textures, or lower the geometry in the scene. I did have to redo the lighting and camera tohugh. It may save you time:


#5

You should also consider optimizing your geometry. It looks like a huge amount of detail. Some of which undoubtedly you’ll never see, from this camera at this resolution. Do like the pros do and remove all vertices/faces/sides/objects that will never be seen.


#6

At the moment i’m resizing some textures which were indeed much to big, especially the ones used on the concrete slabs and it seems to work. There are still a few white spots left. After that i will optimize my mesh which will , i think, eradicate the problem.

Also the scene seems to load much quicker now.

Thank you Eric and Deathcricket for the tips.

Reinier.


#7

Look into the bitmap pager (customise/preferences/rending tab). It’s meant to help when dealing with large textures at the expense of extra rendering time. Haven’t used it myself, but I hear it does help.


#8

I have optimized some objects of the model (deleted about 15 000 unseen polygons)and deleted some other objects which you couldnt see (about 90 000 polys) i could have taken it much further then that but its all working fine again.

Now begins the finalizing of the model and hopefully can post it soon.

@Robinb. i will have a look at those options soon, ty.


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.