Strange Input Device Happenings


#1

Well I have a stumper for you great hardware troubleshooters.

I have a IBM PS2 Keyboard and a M$ Intellimouse Optical which have been good old friends for years. They have been hooked up through a Belkin 4 port KVM for nearly a year and been flawless in operation. About a week ago I started getting all sorts of strange occurances on my computer… the Start Menu would pop-up (as if I had hit the Windows Key), the System Properties page would appear for no reason, the Run command window would do the same. Num Lock turns off automatically, and when it is on the Number Pad still works as if it were off.

I wondered if I was being hacked, but my firewall showed no strange traffic. I wondered if I was infected with some strange virus, but Symantec Corporate comes up with nothing, and I have found no virus descriptions matching my symptoms…

Suddenly some new symtoms have appeared… my mouse functions have gone haywire.

Left-click sometimes will not execute the expected operation. Middle click actually invokes the Alt-Tab window switching. Right-click opens the task manager.

I thought perhaps it may be my KVM switch was on the fritz, but after removing it completely from the setup… the problem persists.

I tried pulling out an old Dell mouse and the same occurs… I tried dusting off and old keyboard but there is no change… this is almost rendering my workstation usless…

Has anyone ever experienced anything like this? Can anyone think of something I can do to remedy this?

WinXP Pro fully updated
Dual MP 2800
4 GB DDR PC2100
Nvidia Quadro4 980XGL 128


#2

That’s odd…corrupted drivers maybe… Have you tried reinstalling the drivers for these? (Control panel->performance&maintenance->system->hardware->device manager, right click->uninstall then reinstall)
Heh, only thing I can think of. You may have some virus that symantec can’t detect (I’ve had a couple like that myself), or maybe the ports they connect to are messed up. If your optical intellimouse is like mine, in that it has a base USB interface with a PS/2 converter, you might try pulling off the PS/2 plug and hooking it into a USB port that you don’t use much.


#3

Must be a lousy title, because only 5 people have read this in 11 hours. =D


#4

Sounds incredibly funky. :argh: I don’t suppose you’ve tried reinstalling your mouse and keyboard drivers? Did you install anything recently prior to the problems occurring?


#5

Can’t think of anything out of the ordinary that I have installed… I have tried uninstalling the MS Intellipoint Software… as well as re-installed it. Did this this afternoon while waiting for a response… Ran Spybot S&D… Ran Adaware… Uninstalled anything that I thought could have an effect:

TweakXP
Most recent Win Updates
Ensharpen Codec - which I had recently installed
Canon Digital Camera Software - recently bought a camera
Even went so far as to uninstall Firefox

It’s getting progressively worse now… I am prolly gonna loose it soon and reformat, if that doesn’t work I’ll likely be in an institution. =D


#6

Maybe your computer is haunted?!?

You said you cleaned out you keyboard, but have you tried another keyboard (that you KNOW works fine)?
Have you tried the MS mouse on another PC (to see if anything goes wrong on that one).
Have you tried some other anti-virus and anti-spyware program other than Norton?
Is this PC kinda old? Maybe its the powersupply that is going on you - time to back up if you can. (Dieing powersupplies tend to do some REALLY funky things to PCs before they die)
Have you tried to unintall TweakXP? That app messes around with the UI, so MAYBE its messing somethiung up.

I ASSUME that the specific mouse/keyboard your talking about is NOT a wireless one - if so, maybe the batteries are dieing and/or your getting some signals from another source.


#7

Actually the Keyboard I dusted off was a wholy different one in the closet… and it didn’t resolve the issue.

Just tried the Mouse on my Laptop, and all seems fine.

Well I don’t have any other anti-virus software, but Adaware and Spybot S&D are not Norton.

The PC is only 11months old and the powersupply is of high quality I guess it is a possibility that it could be the culprit, but I have never seen anything of this type from a PS though… perhaps I’ll see if I can get a good deal on a replacement and swap out to see it that resolves it.

Uninstalling TweakXP is what I did.

The mouse is USB and the Keyboard is PS2… I also tried converting the USB conection on the mouse to PS2 using an adapter… no change.

Thanks for the help guys. I think it is haunted. Anything else I should try before doing a system wipe and buying a new PS if the wipe doesn’t repair it.

This is very aggravating, because this is a fresh file-system… I just did my quarterly system wipe 39 days ago.


#8

I was going to say that “Strange Input Device Happenings” sounds like innuendo for a male health problem.


one suggestion: perhaps the PS2 port on your motherboard is going… if you happen to have USB inputs and a couple of PS2 to USB adapter you may be able to bypass the fault inputs. it’s a unlikely but still worth a try.

/edit: if you suspect a virus and you need a quick fix then try both TrendMicro and Panda’s free online antivirus checks.

good luck JDex


#9

You may be right, but the KVM switch ran through USB, and the mouse natively ran through USB and the problem was present… I am baffled.


#10

hey JDec, i just edited my previous post while you were writing your response. try the free online virus scanners linked above.


#11

Running now…


#12

And if re-running an anti virus program doesn’t work, then might I suggest a good priest… you to to excorsize that PC of yours.


#13

Sounds to me you have hardware problem, likely to do with the motherboard in the area of the system bus. Time to get the PC repair man. You can also confirm first by downloading some system diagnostic program (sissoft snadra for example) and diagnose your system.


#14

Well… there isn’t anything apparant that is wrong with it. I took it to a repair shop (after doing a clean wipe and running every diagnostic tool known to man) and there is nothing wrong with it, infact, the techs were jealous.

So I have an amazing workstation, that I can’t do anything on. :sad:


#15

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.