Strange black pixels using MentarlRay + FG


#1

Hi folks!

I’m having this weird problem using Mental Ray and Final Gather. My scene have a skylight, a direct spot with Raytrace Shadow and 2 omnis to fill the light, all my models I’ve created with edit poly + turbosmooth. So, my animation goes ok, this is frame 85:

It’s all good, but in frame 88 this weird thing happens:

I can tell you that I’ve tryed everything I could imagine, even replacing the direct with a MR Area Spot gives me the same result. I have also tryed playing with FG radius and also raytrace setting for the shadow and for MR, sometimes the black pixels moved but they are always there from frame 88 (87 actually but less pixels) to frame 112 when the turtle set his helmet on the head.

The only solution I came is to render the shadow in another pass and render this scene with shadows turned off and then compose in combustion, it’s working fine but I would like to know if someone have another clue to what is going on here.

BTW, it’s 3dsmax 7.5. :wink:

Thanks in advance for any help and hope you enjoy my turtle. :smiley:

Flávio


#2

this thread may be of some use

http://forums.cgsociety.org/showthread.php?t=281718

i’ll dig through some of my emails when i get home, see what i can bring in from private transactions. i did eventually find an answer, part of which was not using the 3ds ratrace map. also, there was a bump map that was giving me problems. i’ll have to look at the emails to recall specifics.

there are several other threads about this that may be helpful. search for MR+splotch


#3

The problem is always in the mateials. And more precise: the reflection maps. And
more precise: I think is always the Reflect/Refract map. But I was told about other
reflection maps causing problems (but I had no experience of it). So look in the materials
of your turtle-moto and change the Reflect/Refract maps to Raytrace maps.
Am I mistaken?

If I am wrong and you have no Reflect/Refract maps, then try changing the materials in
the Reflection objects in the scene (I see them only in the motobike) using a standard
grey. Change a object material and render, change other object mat and render so
you can find the culprit material.
Then in the wrong material turn off Reflections and I think the rendering now is ok. If not
turn off Bump and render again, else follow turning off material slots to find what is the
map causing the problem.
When you find it please tell about it here. I am curious.


#4

Hey guys, thanks for the help. :slight_smile:

DangerousCliff: thanks, I’ve tried many search but didn’t try “splotch”, I’ve read lots of threads but didn’t find the answer. Since FG is scene dependent, this is the only scene in this animation that shows this splotches and it’s just when the turtle is putting the helmet… looks some kind of joke MR is playing… lol… I’ve tryed merging but it killed my turtle’s rig… :frowning:
The only soution now is to render the shadow in a separate scene with FG off and compose it. But it must be some material problem, I’ve tried to override the material with a gray one and no splotches showed up!


Bao: thanks man, you’re right that the material is causing the problem, and I’m not using reflect/refract maps, I have raytrace material with fresnel reflection in the bike (actualy it’s a moped with rockets… lol) and a standard material in the turtle with no reflection or bump map to turn off, so I’m still tracking down the problem and if you still have any ideas come here and share with us. :wink:

Thanks a lot for the help!

Flávio


#5

Another test, replaced the turtle’s shell material for the gray material and still got the splotch so this is not about one material but how MR+FG manage the whole scene I believe.

Still doing some research… see ya!


#6

Turtle shell? :eek:
What I think is causing the problem is the chrome material I see in the bike.:slight_smile: Go to the materials and change it for a grey material. Then render to view if no other chrome object
shows and the black dots are gone also.
If it is the chrome material then in his reflection slot I think it can be the problem because
I had the same FG black dots and it was the reflection used.
I would try putting raytrace only (without falloff maps) and enter in the raytrace and uncheck autodetect and check reflection to be sure it works as you want.
Tell us.

P.S: Also thinking about being inside the helmet a radioactive pixel perhaps?


#7

I had this problem with FG in Max 6, haven’t seen it since (thank God!) and I had to turn off FG and use GI only to render the scene. I never did figure out the exact reason why though.

However It has just occured to me that the black we are seeing is the background colour. Just out of interest, try changing your environment colour to bright red and see if the splotches change colour?

Also if this happens, maybe try putting an image into the Mental Ray Connections>Environment map slot (click it and choose, I think, 3dsmax Environment and place a bitmap inside that). That should draw the bitmap into any reflection where scene geometry cannot be seen - maybe that will fix it, it’s a guess though, but it worked with an issue I had with transparent objects rendered against non visible objects. Good luck.


#8

Hi folks! Thanks again for the help. :slight_smile:

Bao: well, I don’t know if in the bottom is also a shell or not or how it is called… :stuck_out_tongue:

Well, I think we had many things happening here, first the material, replaced the chrome with a grey and still got splotch. The chrome is also a raytrace material with a falloff map with fresnell, tried replace it with a metal material from MR and still no good. But, as I was checking the materials, I saw that the glass had a multi/sub-object material because I detached it from the bike, then I changed it from de multi/sub-object to the raytrace glass material and I got much less splotches as you can see:

Ok, first lesson: MR+FG doesn’t like an object with multi/sub-object material using only one material. :eek:

Second problem: I put an omni inside the helmet with a negative value of -0.8 to dark the inside of the helmet, just turn it off and… no splotches! :eek:

Ok, again, it seems that MR+FG doesn’t like negative lights as well… but I can’t find out why disabling the main light’s shadow would solve the problem. Also, it seems that the problem was related to the glass reflecting the dark inside the helmet so I tried to play with the trace depth, still the same problem.

Since I still wan’t to dark the helmet inside, I’ll keep the way it was going, rendering the shadow in a separate pass and compose it,

moidphotos: thanks for your help, I also hope never see these splotches again… :smiley:

The problem doesn’t seem to be the background, I have tried change the color, change the map and even puting the background in the MR connect. But thanks for the help. :slight_smile:

If someone still got some idea I’ll give it another try.

Cheers!

Flávio


#9

I remember my scene had also multi sub materials.
I would try substitute the multi sub material in the problematic object
for non multi sub materials. Probably you need break in pieces your object also
to do that.


#10

Does changing the raytrace depth have any effect on the scene/blotches?


#11

Hey Bao, I’ve also seen problems in the past using multi/sub-object with mental ray, but in this case I can’t brake my model in pieces, maybe doing an extensive unwraping I could place all te materials in only one, take a look how it’s the final imagem composed with DOF and particles in combustion:

rlph.: I’ve tried playing with the trace depth and also the raytrace depth and size but didn’t help.

Thanks for the support!

Flávio


#12

Hey guys, sorry for the delay.

Now I have finally got what was going wrong. Basically, it was 3 things:

1 - Lights with negative intensity: it looks like MR and FG doesn’t like it, you can use it but always remember to turn off the specular, it was around 20% off the splotches.

2 - Multi/sub-object materials: MR also doesn’t like it, in my case some unused IDs was givin around 10% of the splotches, removing the unused IDs helped a bit.

3 - Faceted materials: that was the last and biggest piece of the puzzle! I used a raytrace faceted material and just remove the option “faceted” all the last 70% splotches had gone!

So, I hoped it helped some others with the splotch problem with MR and FG. :wink:

Thanks to everyone who tried to help!

Cheers!
Flávio


#13

And thanks to you Flávio for your report of solutions.


#14

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.