Stereoscopic rendering and Teamrender


#1

I need to do some heavy stereoscopic rendering (2k, lots of frames) for an upcoming project. Sadly I just discovered today that teamrender does not support stereoscopic rendering.

Any one here done large scale projects with stereoscopic rendering? Would you be willing to discuss with me the ins and outs?

Thanks!


#2

So I thought I had found a workaround…Was going to use Takes, and switch between the Left and Right cameras in the 3D camera rig, however, when you go to the Left camera, instead of showing the view from that camera, it MOVES THE WHOLE RIG so that the left camera is now where the center was.

Can anyone explain to me what good it does to choose the left or right camera in the camera settings, if it actually moves the rig instead of just showing the view from that camera?

UGH.


#3

I found this plugin Stereo Camera rig script for C4D R15 (don’t know if it will work in R18/R19):

http://reel.svoigt.net/scripts/?mgi_55=698/sv-stereo-rig-pro-v53

The developer says it has Anaglyph preview in the viewport, so maybe you can use this instead of C4D’s own Stereo Camera?

I only have R19 Demo installed, so I can’t help you much further than this.

I hope that the script I found may be a possible workaround for your problem.


#4

Skeebertus -

Thanks. I tried that script yesterday. It kind of works. It’s a bit finnicky and requires rendering larger than you actually need for output.

What I ended up doing was recreating the stereo camera setup and using the “toe-in” method along with film offset to align the camera frustrums. It’s not perfect, but pretty darn close. Close enough for what I need.


#5

Although TR doesn’t support rendering both channels from a single file, you can save 2 project files, or two takes, one for the Left and one for the Right.
In the Render settings, go to Stereoscopic and set the “Calculate Stereoscopic images” to Single Channel.
Left should be “Single Channel” = 1 and Right = 2.

Please let me know if that works for you.
Cheers


#6

DeGamma offers stereoscopic rendering output easily and works with team renderer.


#7

thank you Noseman and Per Anders!

ok that trick with left and right is what I was trying to get working, but I was doing it by switching the 3D camera to “left” or “right” which actually shifts the camera rig??! I can’t understand the usefulness of that, but I digress…

I will do some tests later today with your suggestion. Thanks!

And Per, thank you for the heads up about your plug. I will reserve that as a backup plan.

thanks again guys


#8

Hey GAry

Heres a stereo rig I built several years ago—before stereo got integrated into c4d. You just need to set up 2 takes (or jobs) set to render your scene from the left and the right camera only (assuming you are not attempting to do a one-pass anaglyph type render right o the bat)

Should be pretty self explanatory.
Uses the camera shader to allow you to view via anaglyph mode for testing. You can toggle between all 3 types of stereo, ie offset, toed in and parrallel.
Used it quite a bit back in the day and worked well.

Thanks goes to Tim C from his fxphd class eons ago,

https://www.dropbox.com/s/bzvpv95nmps4ohv/StereoCam_fxphd.c4d.zip?dl=0

Edit–not sure if the anaglyph mode still works. Either its the Xpresso or the camera shader may need to be tweaked. This was built in v11 or 12 I believe so some things might be broke?


#9

Unfortunately, no, this does not work. Anytime stereoscopic is enabled in the render settings, team render does not render properly.

I created a simple scene with some cubes, 31 frames long (0 through 30), camera movement from 0 to 30 using a stereo 3D camera preset.
I set up the save path for the frames as “noseman left” and set it to render channel 1 using your method described in your post.

The results I get in the folder are very strange. First, they do not convert from .b3d. Secondly, the files are somewhat randomly named. I mean I see a pattern, but it makes no sense as to why they are named differently.

Frame 0 is rendered as .b3d and named “Stream Left_nosemanStereo_000.b3d”
Frame 1 through frame 12 is rendered as .b3d and named “Stream 0_nosemanStereo_0001.b3d” (but sequential up to 12)
Frames 13 through 30 are rendered as .b3d and named “Stream Left_nosemanStereo_0013.b3d” (but sequential up to 30)


#10

Actually I just figured out the pattern. Frames 0, and 13-30 were rendered on a PC node, and frames 1 through 12 were rendered on a Mac node.

This is rendering with TR using the picture viewer on the PC, pointed to the PC’s documents folder.

So I tried again, this time going to a network drive.

PC got frames 0, and 11 - 30 this time named “Stream Left_nosemanStereo”…etc)
Mac got frames 1 - 10 named “Stream 0_nosemanStereo”…)


#11

Thanks Joel! Gonna give it a whirl now.


#12

Noseman - thank you!

Tried your method with Team Render to Picture Viewer, and with Team Render Server. Neither really work as expected, however, with Team Render Server, it at least names the files the same regardless of what platform they rendered from. But it keeps them as .b3d and never does the conversion.

Sounds simple enough, but this is a big project that will have many layers for compositing and I’m afraid all this extra file management is going to be a big issue.

Joel - tried your rig, thanks! Unfortunately, out of the box, it is giving me very different results than expected, in fact I can’t seem to even get my eyes/brain to converge the images as they should when combined using anaglyph and viewing with red/blue glasses.

I will play with the settings on it and see if it is user error (very likely since you said you’ve used it with success in the past)

Per Anders - interested in checking out degamma but can’t find specific examples of the stereoscopic use (screen shots of interface or description of how it is used.)

I really need something with the ease of use of the built in 3D camera…but need to be able to network render it.

If the silly built in one wouldn’t MOVE THE RIG when you switch from the left camera to the right one, I could make it work with Team Render.
Still highly baffled by that one. I’d love to understand why it was programmed that way… there’s probably a use case that I don’t understand.


#13

huh–interesting. I havent touched this rig in a long time but it was my go to for all my stereo work prior to maxon adding the tools directly into c4d.
You’ve played with the convergence sliders in the user data? Maybe somethings broken?

I may be able to dig up some other rigs I;ve used that might work better for you.


#14

Another important thing to add Gary–when using the rig–you want to click on the stereo tab of the main parent object. The controls are in there. You want your area of interest in your shot (or whatever objects you are focusing on) to live on the focal plane or around that area for best results. You may need to pull in the interaxial distance so its very subtle (via the slider in the user data) and you can also choose which method of stereo you want depending on how the left and right rendered footage will be processed in the final deliverable.


#15

Thanks Joel -

I bet altering that interaxial distance will be the cure. I’ll keep playing. Thanks again for sharing this!


#16

Yes please check if you can–unless you;ve already figured out one of the other paths.

The whole key to getting the right feel and not going crosseyed is all in the interaxial distance–as well as making sure your area of interest is sitting on or near the convergence plane. You dont want to have objects too close in the foreground or too far in the background if possible either. You’ll find that sometimes just barely opening up the interaxial distance–like even as little as .5 or 2 degrees–is quite enough to get good stereo. Depends on the scale of scene however.


#17

That makes sense. This project will have very wide scenes with lots of depth, to macro scenes where the background is pretty much blurred out. (Though I will need to play with the amount of blur since depth of field kind of works against the whole stereoscopic way of doing things)

Thanks for the input!


#18

I think this issue is something you need to contact Maxon about.
On the other hand, tomorrow (Friday) I’ll be able to test this on a small Mac - PC Rendering network…


#19

I have. The official word is that it is not supported, which is ironic when you consider that stereoscopic rendering requires twice the amount of rendered frames and would benefit from network rendering.

Seeing the render results I’m getting, I can see that it’s pretty close to working, but far enough off that I can’t use it in production. It just needs to name the files properly and convert them from .b3d