SSS shaders cause crashing


This can’t just be happening to me… both at work, and at home on my own license of XSI, I suffer constant crashing when trying to use any of the SSS shaders that come with XSI 4.2.

Does anyone know a solution for this??


I haven’t experienced said crashing… FND and ADV licenses… may I ask if it is happening in very simple, from scratch scenes?


It happens on anything from a cube to a more complex model. I have tried the mi_SSS ones that come with XSI, as well as the Diffusion one by the bigmuh, and yet it’s actually impossible for me to make any progress because it always, always starts crashing. Sometimes it crashes just when adding the node to the Render Tree, or else it’ll crash when I try using the Render Region tool, or even a standard render.

This happens at home with my Advanced license, as well as at work on our Essentials licenses. This has ALWAYS been my experience of SSS and XSI and it’s driving me crazy.


Hmmm… okay. First things first… Hardware? Vcard Driver? OS (w/ SP?)

Seriously Leigh… never had a problem with mi_SSS or Diffusion, at least crashing related.


Thanks for your help, Jdex.

The three machines I have tried unsuccessfully to use these shaders on:

  • dual 3Ghz Xeon, 2Gb RAM, Matrox Parhelia 256Mb card with the latest drivers, XP Pro (SP1)
  • dual 2.8Ghz Xeon, 2Gb RAM, Nvidia Ti4400 128Mb card with the latest drivers, XP Pro (SP1)
  • dual 250 Opteron, 3.5Gb RAM, Nvidia Quadro 4 980XGL with the latest drivers, XP Pro (SP2)



Okay… Matrox Cards and XSI do not a happy user make (at least as recent reports go)… but this sounds unrelated. The Ti4400 is not officially supported… and both could have HT enabled on the processors, which may be a problem… but for now lets focus on the dual opteron w/ quadro (lemme guess, that’s the machine at work, that you can’t get access to right now, right?)

The first glaring overall potential for trouble is Latest Drivers.

Go to and find the certified drivers page (and go download the current certified drivers)… if this does not help…

Rename the users folder to reset the preferences… you can pretty easily recall them later if this is unsucceful in resolving the crashing.

Next I guess you should see if anti-virus, anti-spyware types of processes could some how be interfering with the mental ray process. Disconnect from the web and disable these types of programs to see if you get any improvment…

There are many other things, but if the Dual opteron is available now, try these things first.


Hi. I have uploaded a sample scene that works here. Maybe it helps.



Is the script editor recording any error messages?


jdex… please… :smiley:

MJV, thanks for the scene, no problems here too.
(but where’s the sss ??!)

and…to be true miSSS, not really stable in general,
comes with incredible limitations, and misss_fast
on maya is also really a pain, just take a look at
maya rendering section.



Nuetronic, it’s the skim milk shader.


it was crashing on me with that skim milk shader, sss tends to crash in XSI when u have hard shadows on u can’t use area shadows and u must have the shadow tab enable in the render options, hopefully this helps! just use shadow maps! no area! :thumbsup:



Wow, very helpful responses! Thanks a lot everyone!!! :thumbsup:

I am currently at work and very busy with some stuff, so I cannot check this right now, but if I get a chance to later in the day I’ll try out the test scene (thanks MJV) and also try some diagnostic tests and such… if I don’t get a chance at work, I’ll just do it when I get home tonight!

Thanks again everyone! I’ll let you all know how it turns out!!!


Please what? :slight_smile:


Okay, I tried at work again yesterday (on the dual 2.8Ghz machine), and still got crashing. Using the Render Region tool is a sure way of crashing, but it also crashed when I tried to connect the Skim Milk node to the other node in the Render Tree.

I got home pretty late last night and was really busy with an article so I didn’t get a chance to try it on the Opteron, or to check my drivers, or to try MJV’s scene. I am hoping to get a chance to do that tonight…

THere just aren’t enough hours in the day to get things done!!


did u try the shadow tab like i said?


Don’t we all know that. Let us know the results… there is so many things it could be, but will get ya up and running.


Okay guys, sorry for the late reply on this, this week has been I N S A N E.

Sad news… I’ve tried EVERYTHING suggested, and tried the sample file but nothing works. Crash. Crash. Crash. Here and work, and at home. I can generally seem to connect the nodes without a problem now, but if I try a Render Region or a standard Render All Passes, boom! Bye bye XSI, back to the desktop. It happens every time.

I guess I will give up on it. What can I say, I am really disappointed.

But thanks a lot to everyone for their advice and for trying to help. I do appreciate it.

:cry: :cry:


Did you noticed if the script editor logged any messages? Right before you render a region open up the script editor and see if it records any error when the region is drawn.

You can also have the script editor save a log file if you enable it in the preferences. This will help troubleshoot the problem a bit more. Another thing is right after the crash if you go to Start>Programs>Softimage products click on XSICAB and follow the instructions, this will generate a report about the crash and will mail it to Softimage.


Leigh, have you tried using the Diffusion shader? i skimmed this thread and saw no mention of it. if not, you should really give that a go.


Sorry for the delayed reply here… been terribly busy!

Okay, the good news is that I managed to get the Diffusion shader that Levitateme mentioned to not crash XSI. It seemed to be some workgroup issue - I hadn’t set one up and since I have now created one, it now longer crashes XSI when I load it.


It doesn’t work! I mean, I was playing around with it at work today with absolutely no problem whatsoever. But now, when I have come home, I’ve loaded up XSI and done EXACTLY the same thing as I was doing at work, except all I am getting is a black render here at home, whereas at work I was getting a lovely diffused cube.

Is this shader compatible with XSI 4.2 Advanced? At work I am using Essentials and having no problem. Maybe it is not compatible with my Advanced license?