[Solved] .DDS Bitmap I/O Error: "Failure to Create Direct3D Device"


#1

Hey guys,

I’d like to know if any of you are still running older 32-bit versions of Max on Windows 64-bit OS and have forsaken the .DDS format because of the subject error?

I have compiled a replacement dxDDS.bmi plugin and it solved the error for Max8 on Windows 10 64-bit.

I would like to know what Max versions have this .DDS Direct3D device problem, if anyone still has Max9-2010 32-bit versions on 64-bit Windows to verify problem exists, so I could try to compile versions of dxDDS.bmi for them as well. Thanks.


#2

Seems like this only affected Max8… as others have verified Max9+ don’t have this problem.


#3

yes
I have the same problem in max 9 32-bit on windows 10 64-bit


#4

Really? Ok… could you post a screenshot of the exact error message you get? I thought there was a recompiled DDS plugin already out there for Max9. But if you give me a few days I will recompile the project for 3ds Max 9 32bit and you can see if that plugin fixes your problem. Thanks!


#5

First would you please download and install Service Pack 2 for 3ds Max 9 32-bit. It does fix some issues with the dxDDS.bmi plugin. Here is the link:

https://knowledge.autodesk.com/support/3ds-max/troubleshooting/caas/downloads/content/autodesk-3ds-max-9-service-pack-2.html

See if SP2 solves your issue and post back to let me know. Thanks.