(SOLVED) [C4D/OCTANE] Blackbody casting its own shadow


#1

Hello,

As you can see in the pic, my blackbody object is casting its own shadow, how can i prevent this?
I don’t want to disable the “Cast shadows” option because i need it to affect other objects, i just don’t want its shadow to appear.

Thanks a lot.


#2

There are some great discussions currently on the Otoy c4d forum regarding the use of OSL shaders to control the visibility of different rays rays etc. Ask on there!


#3

Thanks @mitchino for your quick answer, i found the solution and will share it in case someone had the same problem, okay so to prevent an emission object from casting his own shadow, you have to add an “Octane ObjectTag” to the object in question, go to “Visibility” attribute, uncheck “Shadow Visibility” and it’s done.