Soft body simulation switches off when i render with subdivision turned on


#1

Possibly a dumb question but after an hour searching i can’t find the answer<

Hope you can help :pray:

I’ve run a motext soft body simulation (using a great Eyedesyn tutorial). Trouble is:
When I render with the subdivision on, the render ignores the dynamic simulation. See images attached. As soon as i turn off the subdivision, it renders fine. Any ideas what i’m doing wrong?

I’ve tried baking the simulation via project settings and via the tag on the motext object, but this doesn’t help.

Thanks a lot from a C4D newbie

Johnny


#2


#3

Show an image of your Object Manager so people can see how you’ve set the project up or post the scene file.

Quaint to see someone using the Interactive Render Region, that takes me back a fair few years…


#4

Thanks Infograph! Really appreciate your response.

Yes quaint is how I roll, still using R16 (which could be part of the problem). Here’s the project file:


and a screengrab including the object manager:

Since my original post I’ve realised:
— This only affects the interactive render region (old I know but i’m reliant on it)
— The problem only affects MoText objects

It’s possible it could be something in my IRR settings but I can’t seem to figure it out.

Thanks,

Johnny


#5

You’re not the only one who is reliant on the IRR, I used it for many years with Sketch n Toon. :slight_smile:

I’ve just tested your scene in R20 and get the same results. I cached your dynamics and get the same result.

I wonder, could you use a low res object to drive a higher res object with the Mesh deformer? That may work in the IRR as a work around?

I’ve never come across this limitation of the IRR myself but this is surely a bug that you’ve discovered?


#6

Ah phew - just a relief its not me. Ok that sounds like a good workaround, thank you!