Sketch & Toon - Glitchy / Buggy


#1

Trying to render a simple 15 frame sphere rotation (default sphere). I first made the sphere editable then used S&T to make basic lines on all the polygons… Some frames render fine, others are missing some of the lines on the sphere. Lines appear and disappear on various frames. Anyone run into this? Seems like a bug.


#2

Without more specifics on what all of your S/T settings are - it is hard to say, S/T is so complex that you may have set something funny.

I just recreated what you described and all the lines were clean and nice throughout the animation


#3

I have a screen shot… and a quick animation here:
http://www.studiog.tv/ball.htm

Using C4D 9.1 on a Windows XP System…

Could you send me your file that works?.. Maybe
something else is going on here.

you can email it to:
glennsmooth@gmail.com

Thanks!


#4

Strange… I just created a new scene (same thing)… and it worked! I guess the scene I was working with somehow got corrupt?.. no idea, but at least it’s working now.


#5

But, I do have one more question… and that is: Is it possible to get this same number of lines yet have them be smoother and rounder? The lines are following the poly edges so I’m not sure how this can be done. I’ve tried using the “tiles” texture but then the line thickness end up getting pinched at the north and south poles.

Any help appreciated.


#6

it has been a long time since I tried to do this, so there may be a better way now, but I ended up building my wireframe sphere out of parametric splines (each “line” was an individual spline - so it was literally a wire sphere), and then using Paul Everett’s Solid Spline Pro for rendering


#7

Excellent, that’s the answer!.. basically render splines with the Toon shader… this way the lines are all even (no pinching at the poles)… thanks!!


#8

no clue what originally caused your problem, very odd.

As for your question about smoother lines, why not select the edges you have, set selection, then throw the object into a HyperNURBS… Apply the sketch material using a tag instead of rendersettings, and you can restrict the edges to a selection set.


#9

Not sure what the original problem was… but that first file
somehow became corrupt.

Your suggestion works great too.

Thanks!


#10

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.