sketch and toon


#1

Hi guys,

does anybody know how I can get rid of the extra diagonals from n-gons in the render?
I need to render wireframe, wich of course should look as clean as possible:


red/dotted: problematic zones…

Thanks for advice!


#2

You can also try the Cel Renderer (under the “Effects” Tab in the rendersettings). This should give you clean lines and it’s also faster.


#3

Doesn’t do the trick…


#4

Use EdgeSelection(s) in the S&T Tag.

Cheers
Lennart


#5

Here’s a “not so elegant” solution for you, which I managed to quickly try out. So I’m not sure it will work for all circumstances.

  1. Select all the edges of your object and “Edge to Spline” them. Then switch off the “edges” option of your line material or, if you don’t have line material tags, switch it off in the render settings.
  2. Next, switch on the “spline” option.
  3. Under “Hidden Cull”, select the “Objects” option and remove the tick from “Self Culling”
  4. Drop your object into the “Objects” list box

This works perfectly here. Hope it works for you too.

I suspect if you have multiple options, you will have to have line material tags for each object to avoid linse from shining though objects that’s in front of others.


#6

Yeah, got it to work! The tricky part was: The object is in a C-NURBS, which -even with zero subdivision- obviously creates diagonals which are rendered in S&T. After turning the C-NURBS off (which luckily makes no difference in the Cel render), I got clean n-gon outlines with the edge-selection method… phew!


#7

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.