Sketch and Toon animation problem (flickering).



I am doing very easy animation with SaT, but heavy flickering (actually more than that) occures. You can see the video here:

There is nothing more than 3 cubes which are downsized and moved away. They are single objects from the beginning to the end. Somewhere in the middle of the video SaT seems to draw also “triangulation” lines on the ground plane. I tried different settings, but it has never been good (actually it was even worse).

Render settings: nothing spectacular, just “normal” line antialiasing in SaT render settings, geometry in overall AA settings.

Thank you very much for any help.



Try converting those edges that you want as splines.
For “live spline(s)” with Edge Selection Tags option
you might try splineCAGE from my sign.

Then in S&T use the render splines option



Thank you for the help. SplineCAGE works really nice! I downloaded also the splineGlide - that looks like really useful plugin!

I just solved the problem with flickering by deleting all the Sketch Tags I had on the object and rendering the scene with global settings. Probably I had some mistake in “Replace All”, “Replace Lines”,…etc.

I think, I will have more questions in the future regarding SaT (my first animation - in Stills I was faking unperfect renders in PS).



I have new problem with AA and SaT. In the enclosed picture you can see that the lines on the left side of the house are perfectly antialiased, but the lines on the house front are jagged. Where might be the problem? Line AA is set to “Best”, nothing else should matter.




Is each brick a separate object that you are then tracing all edges on?

You may be generating overlapping lines that it is not sure how to anti-alias.

In the advanced settings for a sketch material you have the option to filter strokes via the strokes channel.

perhaps this would help.

it’s hard to give a proper answer though, an example file would be most helpful in situations like this…where it may be multiple things, or where the system in use has a few hundred options.


First of all thanks for the reply.

The bricks were separated blocks, but I merged them together. In either way were the lines rendered the same.
I thought it might be the problem with the overlapping lines. Interesting, that on the left side of the building, they are perfectly antialiased.

Unfortunately this didn´t work.

Yes, sorry, my question was really very vague. Here is the file, in somebody have time, please, have look at it.



Looks like it is the filtering that is performed by the AA.
your lines are 2 px wide, and thes the S&T filter smooths that out.
The standard AA filter then runs over top of that further breaking down the line.

Turn the AA in S&T off, and just rely on the AA from the render engine itself, this seems to produce much better results.


That works! Thank you! Its also so much faster! I have always thought, that SaT lines are influenced only by SaT “line AA”.

I found also one interesting thing:

In the previous example (with the jagged lines) I had default gray Cinema material on all objects, SaT line material on the top of it + 2 lights with intensities 150% and 300%, so that I get white color on the sunny side and light gray on the shade side.

But when I change materials from default gray to pure white (with SaT line material) and use 2 lights with intensities 100% and 50% the lines are also good antialiased, even if I use the AA in the SaT render setting. And I get of course white color on the sunny side and light gray on the other side.

But the method with only global AA settings works in both cases.

Thanks one more.



This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.