Skeleton foot joints always jump back to original position on playback


I have a rigged/skinned character that I’m doing a bit of animation with. Unfortunately, it came with the foot/toe joints slightly angled downward so they’re not completely inside the skin mesh. After adjusting the position so that things appear fine and rebinding the skin, I can select ‘Go To Bind Pose’ and all looks as it should. But…
Whenever I begin playback the foot joints invariably jump back to the original position pulling the skinned foot into a bad downward arch. For the life of me I cannot seem to get rid of whatever is remembering that old original setting of the foot joints.

I’ve tried almost everything I could find online and on Youtube. The latest thing I thought might work was to export the skin weight map, then unbind the skin and adjust the joints as needed, rebind the skin, and then import the skin weight map back in. That all seems to work as it should. I’ve also tried deleting history on the skeleton and skin before the above changes, and then once everything was set I tried deleting history even before testing the playback. I’ve even tried making/rebuilding a new cache. So far even starting to build a new cache seems to cause those foot joints to immediately revert to the old angled position and I’m back to square one! Very frustrating to say the least.

Can anyone point me to a solution that will once and for all let me adjust skeleton joints and rebind the skin and once and for all get rid of whatever seems to be holding the old position? I’d appreciate it!